SageBrush
Posts: 1500
Joined: Sun Mar 06, 2011 2:28 am
Delivery Date: 13 Feb 2017
Location: Colorado

Show Google Photo in Post

Sat Nov 11, 2017 10:18 pm

The trick is to get the photo link
Neither photos.google.com or .gl URL work

Open the photo in Google photos
Right click on photo, choose copy image address

In forum embed in <img></img> tags
The link suffix height can be deleted and the width modified

Here is an example, photo chosen because I am hungry.
If you start a reply, I think you will see the photo code

Image
Last edited by SageBrush on Mon Nov 13, 2017 5:01 am, edited 1 time in total.
2013 Model 'S' with QC & rear-view camera
Bought off-lease Jan 2017 from N. California with 63.9 Ahr after 22k miles
Car is now enjoying an easy life in Colorado

garsh
Posts: 1078
Joined: Sat Feb 12, 2011 5:27 am
Delivery Date: 05 Apr 2012
Location: Pittsburgh PA

Re: Show Google Photo in Post

Sun Nov 12, 2017 4:03 am

Two caveats:

First, you should "share" the photo by link. Otherwise, it may be private to you, and others won't be allowed to see it.

Second, the direct links to pictures on Google Photos are not guaranteed to stay the same. After several years, you'll find that the photos you attached in old posts are broken links.
2012 Black SV w. G35 wheels, 8 bars, 86,000 miles

SageBrush
Posts: 1500
Joined: Sun Mar 06, 2011 2:28 am
Delivery Date: 13 Feb 2017
Location: Colorado

Re: Show Google Photo in Post

Sun Nov 12, 2017 6:06 am

garsh wrote:Two caveats:

First, you should "share" the photo by link. Otherwise, it may be private to you, and others won't be allowed to see it.

Second, the direct links to pictures on Google Photos are not guaranteed to stay the same. After several years, you'll find that the photos you attached in old posts are broken links.

Good points.
Do you know of a way to use the Google photos indirect link in this forum ?
2013 Model 'S' with QC & rear-view camera
Bought off-lease Jan 2017 from N. California with 63.9 Ahr after 22k miles
Car is now enjoying an easy life in Colorado

garsh
Posts: 1078
Joined: Sat Feb 12, 2011 5:27 am
Delivery Date: 05 Apr 2012
Location: Pittsburgh PA

Re: Show Google Photo in Post

Mon Nov 13, 2017 2:52 am

SageBrush wrote:Good points.
Do you know of a way to use the Google photos indirect link in this forum ?

No. For some inexplicable reason, the ability to include photos in third-party forum posts is not one of the Photo teams's goals.
It's quite infuriating.
2012 Black SV w. G35 wheels, 8 bars, 86,000 miles

SageBrush
Posts: 1500
Joined: Sun Mar 06, 2011 2:28 am
Delivery Date: 13 Feb 2017
Location: Colorado

Re: Show Google Photo in Post

Mon Nov 13, 2017 4:57 am

garsh wrote:For some inexplicable reason, the ability to include photos in third-party forum posts is not one of the Photo teams's goals.
It's quite infuriating.


Now that I know how to find the direct link that works I'm not too put out, but I am interested in why the problem exists.
Is this a case of Google restricting the 'share' icon to only operate in a Google space (Docs or Photos) ?

If so, I can sort of understand the motivation since the Google space has a lot more functionality than a simple displayed photo. OTOH it smells a bit like the old 'extend and embrace' days of monopolistic MS or Apple. Not the same, since the direct link exists and works fine, but a coaxing push in that direction.
2013 Model 'S' with QC & rear-view camera
Bought off-lease Jan 2017 from N. California with 63.9 Ahr after 22k miles
Car is now enjoying an easy life in Colorado

garsh
Posts: 1078
Joined: Sat Feb 12, 2011 5:27 am
Delivery Date: 05 Apr 2012
Location: Pittsburgh PA

Re: Show Google Photo in Post

Tue Nov 14, 2017 4:39 am

SageBrush wrote:Now that I know how to find the direct link that works I'm not too put out, but I am interested in why the problem exists.
Is this a case of Google restricting the 'share' icon to only operate in a Google space (Docs or Photos) ?
No, it's just Hanlon's razor. The photo store wasn't designed to maintain immutable URLs for individual photos. It mostly does, until it doesn't.
2012 Black SV w. G35 wheels, 8 bars, 86,000 miles

SageBrush
Posts: 1500
Joined: Sun Mar 06, 2011 2:28 am
Delivery Date: 13 Feb 2017
Location: Colorado

Re: Show Google Photo in Post

Tue Nov 14, 2017 8:41 am

garsh wrote:
SageBrush wrote:Now that I know how to find the direct link that works I'm not too put out, but I am interested in why the problem exists.
Is this a case of Google restricting the 'share' icon to only operate in a Google space (Docs or Photos) ?
No, it's just Hanlon's razor. The photo store wasn't designed to maintain immutable URLs for individual photos. It mostly does, until it doesn't.

You are using language I may understand correctly, but it sounds like you are just rephrasing what is known; that the the .gl and photos.google.com URLs are indirect references.

So the question remains why the forum cannot pass the indirect reference to a Google server, let them translate the indirect link and return the photo. The answer would seem to be that Google only displays the photo in its own Google environment.
2013 Model 'S' with QC & rear-view camera
Bought off-lease Jan 2017 from N. California with 63.9 Ahr after 22k miles
Car is now enjoying an easy life in Colorado

garsh
Posts: 1078
Joined: Sat Feb 12, 2011 5:27 am
Delivery Date: 05 Apr 2012
Location: Pittsburgh PA

Re: Show Google Photo in Post

Wed Nov 15, 2017 8:43 am

SageBrush wrote:You are using language I may understand correctly, but it sounds like you are just rephrasing what is known; that the the .gl and photos.google.com URLs are indirect references.
Let's make sure we're on the same page. ;)
If I go to a photo in Google Photos, go to sharing, and click "Share Link", it gives me one of those .gl links.
Here's that link for a photo showing the nice crack I got in my Leaf's windshield a couple weeks ago:

Code: Select all

https://photos.app.goo.gl/dApogOwmg9ZjxYGo1

If you go to that link, it forwards to a URL for a Google Photos Album.
The link is for an album, not for an individual picture. No, I don't know why the photos team thought this is what people would want.
Anyhow, the album contains only our one shared picture.

Code: Select all

https://photos.google.com/share/AF1QipO3SnuIggVMz3GynShuqtJcfzTPQ44DFmabiD4gr6_SCapCKWQJZ4tUugI3rL86xw?key=bEdfSHhQWTgyd0tKV1AzWGFJVF9CX2NHSWY1NkJR

So far, neither one of those links is for the picture itself.
Next, if you click on the photo displayed in that album, it takes you to another URL. This shows only that single photo, but with various Photos tools for editing & sharing.

Code: Select all

https://photos.google.com/share/AF1QipO3SnuIggVMz3GynShuqtJcfzTPQ44DFmabiD4gr6_SCapCKWQJZ4tUugI3rL86xw/photo/AF1QipOkGrdv-9bJGiige0v9pid1paGCbBpRbSPHjfGY?key=bEdfSHhQWTgyd0tKV1AzWGFJVF9CX2NHSWY1NkJR

To get the link to the *actual* picture file, you now need to right-click on the photo, and select "Copy image address". Now you *finally* have a URL for the actual JPEG image. It's an extremely long, god-awful mess of a URL. This is what you can embed into forums, with the caveat that Photos might change the URL at any time.

Code: Select all

https://lh3.googleusercontent.com/Hgnw_d-zBYFTwRdNpZIhMZwLGslr-dJNVnOzSF8XpeJpWoOPPND218JLtsqm52IpT3tx6RxA2qoY3qt7yHUhtjsvjMVlj7gtU3EaypggMlnFSSU-yYBg_O9gICh7nWYiNS2JnCktQMuuP2I9F0QkQHEVFQAGh0nBLEpGaI4_qwhf6QceoM46WOTam83r_yjXEt_aPtxP1k8xbVadSHIOCObOHoOvc_hOxB9aXnUyfW4dx_TV8nPyU2rfm37rWtY4AXVIbSnbQp6HxOph7qhu_56kRbUxoheOHcAZ_8T3ucAnn93Q2KjWDouytQbLW--bTmUKMjLCrBScLmYOi6AgToLRmPvoQ73BCBxCAjn0Ado2URs9PKSV4YAAj0JCQS2m5QluvcL9K8jCj1960XOpeg-eyIalCq7s3UPINrPIxi_D0W8D3iwRlCNnVz9YZY63PzjVgVU8ckgEG6yeosqQ9qQfGcy8AGKPnjEsZE47cYAdCMqdHyptbWdMYLsAgqR-UZVrg4cTRaGfEY9RXXyqodPaT5AZZx5-qb1iqWO8YDHEHPblTPKbP5iiOxQeb_mwFoNv8MAJrVZ89giy35IIhisd8XQxHXSCBbgHAW0tP34uKquNY2X7LVkbEWtjfILolTPNWid_NZwZbsl1tjRuyGYkVUb1Y1l9sGc5=w2440-h1830-no

So the question remains why the forum cannot pass the indirect reference to a Google server, let them translate the indirect link and return the photo. The answer would seem to be that Google only displays the photo in its own Google environment.

I suppose forum software could try to be smart, and go through all of the steps that I gave manually above. That way the forum could continue to show the correct Google Photo even when they change their storage algorithm, because that original .gl link *is* guaranteed to continue working. It would be even nicer if Google just presented a link that would either directly, or through a simple browser redirect, gives you the JPEG file.
2012 Black SV w. G35 wheels, 8 bars, 86,000 miles

SageBrush
Posts: 1500
Joined: Sun Mar 06, 2011 2:28 am
Delivery Date: 13 Feb 2017
Location: Colorado

Re: Show Google Photo in Post

Wed Nov 15, 2017 11:52 am

Well described Garsh, and on reflection an answer to my question can only really come from Google. In the meantime I'll continue to think that Google is gently twisting our collective arms to use the Google environment for photo viewing.
Or Google can add a switch to the .gl URL that returns the photo.
2013 Model 'S' with QC & rear-view camera
Bought off-lease Jan 2017 from N. California with 63.9 Ahr after 22k miles
Car is now enjoying an easy life in Colorado

Return to “Website/Forum Discussions”