ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Thu Oct 19, 2017 8:55 pm

What happened was two or three weeks ago and this may or may not be related. the original charger cable stopped working, upon investigation a simple transformer was fritzed, I ordered a Jaycar P2007, I had a Mitsubishi one given to me so while i waited i used that, after a week of working as usual, it charged to 65% and stopped and started a few times,, same at a public slow charger, it took a charge from the fast charger in town no problem then later that day wouldn't, went into crawl mode with ! mark on, now its sitting there with 15 odd km in. No smell like you describe.
Thanks for the tip on the images as well, finally posted now above hopefully.
I trolled the net for the manual and found it in heaps of files not one so far be great to get a copy from you if its easier to use? tcv@orcon.net.nz

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Thu Oct 19, 2017 10:30 pm

Yeah, my copy is a heap of files as well, so no luck there.

The one you want is 'vc - Vehicle Charging System'. Page 23 and on are DTC descriptions.

So you didn't charge the car with the repaired EVSE, just the Mitsubishi one and it was working fine originally on the Mitsubishi one?

Does sound a bit more like the charger has gone weird to me. That would be where I would start, but it's a big thing to swap just as a test. I've still got the spare control board from the one I removed and it looked fine, but mine was showing the same issues as yours: CAN comms issues. At the very least, it gives something that could be changed if the charger gets pulled and the controller is compatible (would depend on the charger version, most likely).

The issue is that you really need access to a charger to borrow to test, unless you remove it, pull the covers and see obvious damage.

The HV battery and charger comms error will be tied together because they're on the same CAN bus.

I'd probably try clearing the DTCs and see what comes back. If you get both straight away then one is holding the bus in fault. If you get just one and not the other, that's probably the issue. If you get both but can still see the battery stats updating then it will be an intermittent issue and the BMS is still talking, so it's the charger.

Second cheapest process will be to uncover the charger and check all the cables/connectors etc. Unplug the charger comms, clear the DTCs and see if the HV battery still faults (it shouldn't).

See where you go from there.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Fri Oct 20, 2017 9:07 pm

OK thanks again, right well seems both faults come back when i clear the DTC's and battery stats are still updating.
I unearthed and unplugged the charger turned the car on and cleared the codes but they still fault

any more clues most welcome!
With battery charger disconnected(left) and Yesterdays
Image Image

GerryAZ
Gold Member
Posts: 1495
Joined: Mon Nov 22, 2010 6:47 pm
Delivery Date: 12 Jun 2011
Location: Phoenix, AZ

Re: 2011 - Dead Battery Charger

Fri Oct 20, 2017 9:24 pm

If you are really getting all of the DTCs cleared and the same ones come back, you need to take a good look at your 12-volt battery. The brake power supply, multi AV, and TCU errors have nothing to do with the EV system, but will be affected by weak 12-volt battery. Be aware, that you must read and clear DTCs several times with LEAF Spy to get all codes cleared because it only clears codes from one module at a time.
Last edited by GerryAZ on Fri Oct 20, 2017 11:19 pm, edited 1 time in total.
Gerry
Silver LEAF 2011 SL rear ended (totaled) by in-attentive driver 1/4/2015 at 50,422 miles
Silver LEAF 2015 SL purchased 2/7/2015

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Fri Oct 20, 2017 10:27 pm

Yeah, gotta agree with Gerry there, looks like the faults might not be clearing correctly?

Did you disconnect all of the connections for the battery charger (including all the little low voltage connections)?

Odd that the USB overcurrent DTC didn't clear.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Fri Oct 20, 2017 11:50 pm

Yes it would seem they are not clearing correctly, brake power supply, multi AV, and TCU cleared ok, EV/HEV and HV not.

yes i disconnected both big ones and all 3 black smaller12v ones.

I am pretty dumb, i could well be overlooking something simple, I checked and double checked the 12v battery, auto sparky put it on a load tester, no problem he says, it reads 12.75 now, i fiddled with the earth, it looks sound and tests the same voltage as across the battery.

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Sat Oct 21, 2017 12:56 am

No worries, not dumb, it's annoyingly fiddly at times.

Sounds like you're heading in the right direction, just need to get the DTCs cleared.

I'd say take another few stabs at getting the DTCs cleared using LeafSpy and see what happens.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Sun Oct 22, 2017 9:38 pm

Ok so repeatedly clearing the DCTs is not working for me so far, I tried with the cars battery charger plugged in and out, i made sure the 12v battery has been plumped up on the trickle charger and been uncoupled with the car for hours. I tried at least 10 times on 3 separate occasions.
I been reading, you may have seen the kiwi with a blown diode in the charger? Apparently I should get a 5v reading off the right hand small pin at the charging port, he instructs on how to test the diode in question using the resistance of the left hand pin, in my case it appears there is no voltage or resistance difference as described.

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Sun Oct 22, 2017 11:00 pm

I haven't seen that one. Got a link there?

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Sun Oct 22, 2017 11:58 pm


Return to “Problems / Troubleshooting”