JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Mon Oct 23, 2017 12:12 am

Yeah, so sounds like something is toast on that CAN link.

So, you're getting DTCs and the CAN error, so it's unlikely that you've got the same issue as in the video, but you should be seeing the 5V detect voltage on the pilot pins. Double check the multi-meter by testing across the 12V battery. If that looks good then it certainly seems like the charger is a bit unhappy.

I'd pull the terminals to the charger and use the pinout in the vehicle charging portion of the service manual to find out which pins should be +12V and GND to the charger power supply (page VC-26) and verify that you're getting the correct +12V on the pins when the car is off/on.

If there's 12V getting to it and you're not seeing the 5V that should appear on the pilot line then it seems like the next step might be replacing the charger.

Do you have the part number available for the charger?

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Mon Oct 23, 2017 12:55 am

Is this it?
Image

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Mon Oct 23, 2017 1:25 am

Yeah, that's it.

Mines a 3NA3A. I've got a spare control board but no idea if it's good.

I'd take a look around for a charger from a wrecker or on ebay and swap it out.

There are also some guys you could try to see if they've got any leads for a spare to try. Bluecars might have an idea or a guy on the Facebook NZ EV Owners Group called Yury who does work on battery pack reconditioning.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Mon Oct 23, 2017 7:52 pm

I studied the wiring diagram and if i interpret this correctly the 12 pin low voltage black plug should have multiple pins with 12v in. I have ascertained that two pins are live when the car is on or off and several more pins liven up to 12v when i turn the car on, naturally I can examine this further and unravel it entirely but for the moment I am assuming power supply is intact.
As for the pilot pin 5v - no, car on or off i get a 1.2v reading.
So If indeed I need a new charger and this is seeming more and more likely, the question now is Part No. 296A0-3NA0A ok to be Replaced By 296A0-3NA8A? or 2A both of which i can find new, no reply's yet from Bill at blue cars or Yury
My car was first registered in japan in Feb 2011

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Tue Oct 24, 2017 11:45 am

When I replaced mine, I deliberately grabbed the exact same model.

I don't think there would be any (probably just revision numbers) but I can't say for certain without units floating around to test with.

If you can't get the exact one, I'd probably go with whichever is cheapest. Where are you checking? I managed to find one in the US through ebay but there were quite a few listed in other ways. A few guys on here were helpful in pointing some out but a couple weren't willing to ship the units.

The other thing is if you get it out, pull the cover off (need some external torx sockets, from memory) and grab some photos. If it looks really similar to mine, I have a spare control board that looks fine and you could try to swap in.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Wed Oct 25, 2017 1:12 pm

I have a reply from Nissan, they suggest I take the car to Auckland for possible software updates,
what do people think??
They say..
Our research shows that there is software updates available for Nissan Leaf that could be applicable to your fault that you are experiencing. These software updates can only be issued by an authorized electric vehicle ( Auckland, Christchurch, Wellington) Nissan dealer who has access to that software.
Our recommendations are that you try that first, the fault codes given to you indicate a communication error and battery voltage abnormal. This may be resolved by checking the software and its integrity.
A price on the charge pack 296A03NA0A is $7838.64 + GST, if this is in fact faulty it may have been caused by the software not being updated so again I would recommend insuring that this is dealt with first.
Hope this further information is useful and we believe that your next action is to have your software checked and verified as being current and possibly some further confirmation diagnostics to confirm that the control unit or battery is the cause of your problem.
I would also suggest to swap a charge lead with a follow leaf owner as this is inexpensive to achieve.

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Wed Oct 25, 2017 1:30 pm

That's definitely an interesting response. Any word on how much they would charge for going through and confirming the software is all up to date? That's something I've been wanting to do on mine to potentially solve some weird braking issues.

I think it's still pretty unlikely there's anything too wrong with the pack if it looks ok via LeafSpy and is still running.

ewaka
Posts: 13
Joined: Mon Oct 16, 2017 10:09 pm
Delivery Date: 17 Oct 2017
Leaf Number: 001294

Re: 2011 - Dead Battery Charger

Wed Oct 25, 2017 4:31 pm

Yeah its still running - in turtle mode - yours did that too I understand?
I rang Nissan takapuna as recommended by Nissan whg, I got a sensible bloke on the shop floor who said well look its got a problem they know nothing about and couldn't fix so they send it to us, we have to start from the beginning, Id like to tell you its as easy as a software problem but i will tell you now its not, these cars dont have a problem with this full stop. It could take and hour it could take ages to track down your issue etc,, not possible to quote a price. I explain where I am at, he says certainly have a crack yourself, we are here if you get in to trouble.
I got a second hand charger lined up from Bill $800+gst and transport, he says sold a few, this is the last one left, they seem to have a little bit of a problem.
Whats the weird braking issue you have got?

JonoNZ
Posts: 27
Joined: Mon Jan 11, 2016 4:10 pm
Delivery Date: 11 Jan 2016

Re: 2011 - Dead Battery Charger

Wed Oct 25, 2017 4:40 pm

Yeah, same deal here. If the battery was anything too horrendous, it would either be stock still or not reporting via LeafSpy. That's what mine did and the 'fault' as far as the vehicle was concerned was that the on-board charger wasn't communicating on the CAN. It wasn't communicating because it was toasted and pulling the internal supply voltage down, but the car didn't know that.

That seems like it's probably the best way forwards. It's a pretty easy swap (biggest pain is the coolant and replacing the seats). The HV connections can be a bit of a fiddle to get them to unlock, but just check the service manual and it'll explain it.

That response from Nissan Takapuna sounds pretty good, actually, I'm impressed. I'd always rather deal with someone like that than get the whole run-around, meaningless quote, etc.

Interesting that they have a bit of a problem, so far I was still the only person I'd heard of replacing theirs, so I was hoping it was a bit isolated.

The braking issue is just that it seems to randomly get really touchy and hard to stop smoothly. I've seen quite a few people mention it and seen it get blamed on 12V battery issues, firmware, sticky rotors/calipers, all sorts. It's not enough to be an issue to drive, it's just a little annoying. It normally clears up for a bit if I come to a complete stop and give the pedal a good long/hard/slow press.

Anyway, like I said, try pull the cover off once you get it out and grab a few photos. If the controllers look the same then there might be a way to salvage the old one, once you've got a working one to test against.

rpmdk
Posts: 146
Joined: Thu Jan 06, 2011 12:22 pm

Re: 2011 - Dead Battery Charger

Wed Oct 25, 2017 11:09 pm

Last Friday morning I went out to the car and experienced that burnt plastic smell. Yet the car had completed its charge and was ready to go. Since that morning I haven't had a problem charging it.

A couple of times the week before there was an error message that charging had been interrupted, but it appeared to be at the full 80% I had set the timer for anyway.

I was going to make an effort to get it to the dealership as soon as possible, but I haven't had a problem with it since. It's always charged to a full 80% and I haven't noticed the burnt plastic smell again. So I'm going to take it in when it's convenient.

Any ideas what else might have happened overnight on that first Friday? Any concerns that I should get it to the dealership ASAP?

Return to “Problems / Troubleshooting”