Bigboler
Posts: 47
Joined: Fri Mar 23, 2012 11:02 pm
Location: Vancouver BC

Re: Charger wiring harness with a dead wire

Thu Dec 14, 2017 8:16 am

In the end I picked up a used on board charger from the wrecker in Tacoma, the part number was from an earlier revision but I plugged it in and hooked up the cooling and it's working just fine.

If anybody runs into this problem in the future, consider a path other then just going to the dealer. I was quoted $2000 to replace the cable from charger port to charger, and $4500 to replace the charger (remember this is Canada were everything is more expensive) the work to replace the charger is not complicated, any competent home mechanic can do it. Just pay attention to the unplugging of the high voltage stuff and follow the fsm and you'll be fine.

Watch this video it will help in the process, https://www.youtube.com/watch?v=5R4dGg8nIUs

And thanks for all the help from the Leaf community, groups like this are some of the best parts of the internet


Paul

alozzy
Posts: 756
Joined: Fri Jan 20, 2017 4:25 pm
Delivery Date: 18 Jan 2017
Location: Vancouver, BC
Contact: Website

Re: Charger wiring harness with a dead wire

Thu Dec 14, 2017 11:16 am

Awesome! Glad you were able to resurrect your Leaf without getting fleeced by a dealership.

If you don't mind me asking, how much did you end up spending to do this repair?
Vancouver, CA owner of a 2013 Ocean Blue SV + QC, purchased 01/2017 in WA
Zencar 12/20/24/30A L1/L2 portable EVSE
1-1/4" Curt #11396 hitch
After market, DIY LED DRLs
LeafSpy Pro + Konnwei KW902 ELM327 BT OBDII dongle
Loving my first BEV :D

Return to “Problems / Troubleshooting”