JRoque
Posts: 37
Joined: Sat Jul 11, 2015 4:44 pm
Delivery Date: 29 Jun 2015
Leaf Number: 406755
Location: Miami, FL

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Wed Aug 30, 2017 2:41 pm

Leafboy wrote:Curious.........how was this procedure figured out???


Cursing was used, tears were shed, blood was spilled, nightmares ensued, heads went bald, marriages were broken... then someone pulled up the schematics and followed the lines to the 3G radio.

For me it came when I figured something was up with the radio because my 12V battery would die the days after the Carwings website/app was down. My radio would get stuck, I thought. Rather than pulling fuses, declining data being sent to Nissan and removing any other option that would cause it to up/download data worked around the problem. If I just reset the modem it would work for a few days and my 12V battery would die again.

I wouldn't have to be pushed too hard to be a willing participant in a class-action suit against Nissan to get them to fix this fiasco once and for all.

JR

Supersleeper
Posts: 79
Joined: Mon Aug 07, 2017 10:04 am
Delivery Date: 06 Aug 2017
Location: SF Bay Area

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Wed Aug 30, 2017 10:04 pm

I was considering upgrading my TCU, but wanted to find out how many are actually experiencing this issue and how many are not. Wat are my chances of a successful installation?

cwerdna
Gold Member
Posts: 7185
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Thu Aug 31, 2017 1:41 am

Update to my post at viewtopic.php?p=502854#p502854.

Of course after I pick up my car from the dealer to have them do the lame "required" annual battery check, after charging at work, I get the yellow ! car light and DTC P3131. And, it didn't send the email for charging complete either. I was hoping the problems would repro BEFORE I brought it to them.

So, it doesn't look like a compat problem w/charging locations saved w/the old TCU. I've deleted the only unplugged warning location and cleared the DTC. Let's see if it returns.

At least I think I know how to eliminate the problems completely, but then that means I lose some of the benefits of the upgraded TCU.
Supersleeper wrote:I was considering upgrading my TCU, but wanted to find out how many are actually experiencing this issue and how many are not. Wat are my chances of a successful installation?

Depends on how much the experience the dealer has. You probably will be able to get it to work eventually, but it could take more than 1 dealer visit and several phone calls to EV support w/a bunch of waiting for days or weeks in bteween. That doesn't mean you won't have the other probs (e.g. yellow ! car light + DTC P3131). And, there's the possibility of 12 volt drain that others are encountering.

'13 blue Leaf SV w/premium package (owned)
'13 blue Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

User avatar
SalisburySam
Gold Member
Posts: 193
Joined: Thu Sep 27, 2012 11:01 am
Delivery Date: 24 Feb 2012
Leaf Number: 018156
Location: Salisbury, NC

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Thu Aug 31, 2017 5:31 am

Supersleeper wrote:I was considering upgrading my TCU, but wanted to find out how many are actually experiencing this issue and how many are not. Wat are my chances of a successful installation?

My upgrade works, and has since install. No failures, no DTC's, no dead batteries, only 1 dealer visit, no calls to Nissan. I can only assume correct planet alignment on installation day.
SalisburySam
-------------

2012 SL Super Black
Registered to order: April 20, 2010
Ordered: December 6, 2011
11,900 miles, 10 bars showing, 75% SOH, 49.80 Ahr

User avatar
Stanton
Forum Supporter
Posts: 1944
Joined: Thu Feb 03, 2011 10:56 am
Delivery Date: 01 Sep 2011
Leaf Number: 7458
Location: Plano, TX
Contact: Website Twitter

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Thu Aug 31, 2017 7:52 am

Leafboy wrote:
I didn't pull the fuse again, but I tried it the next day and it communicated for the first time since May! I did drive it after I pulled the fuse and it sat overnight. Maybe it needed a reboot before the fuse pull trick works. We will see if it continues to work.
Curious.........how was this procedure figured out???


I think using the word "procedure" might be a bit generous. ;)
I'm not the one who figured it out, but the reasoning is logical: if the TCU is in fact "timing out", then a "reboot" of the module would probably correct that. Luckily, there's a simple way (fuse #34) to power cycle that module without too much difficulty...and it obviously works. :D
I simply put a sticky label on the fuse holder/cover so I don't have to "hunt it down" every time my car stops communicating.
2011 Blue Ocean SV w/floor mats & window tint
12v LiFePO4 battery & FIAMM 74100 horns
Wet Okole seat covers (front)
Tor's low-power heater mod
2013 sun visor
3G modem upgrade
L2 EVSE Upgrade
Battery Pack replaced (Rev E) @51 months and 41k miles

User avatar
jlv
Posts: 548
Joined: Thu Apr 24, 2014 6:08 pm
Delivery Date: 30 Apr 2014
Leaf Number: 424487
Location: Massachusetts

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Thu Sep 07, 2017 12:35 pm

I realized I hadn't seen a charge completed notification in 2 weeks. Couldn't update the car state from the app or website. So I pulled fuse 34 and it's working again.

Interestingly enough, the TCU was still working when it polls ("update stations" and the like); it just didn't work to send out updates.
'13 SL+Prem (mfg 12/13, leased 4/14, bought 5/17)Tesla S 75D (3/17)
Model 3 reservation
(Probably no LEAF2 for me)

GerryAZ
Gold Member
Posts: 1451
Joined: Mon Nov 22, 2010 6:47 pm
Delivery Date: 12 Jun 2011
Location: Phoenix, AZ

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Fri Sep 08, 2017 12:31 pm

jlv wrote:I realized I hadn't seen a charge completed notification in 2 weeks. Couldn't update the car state from the app or website. So I pulled fuse 34 and it's working again.

Interestingly enough, the TCU was still working when it polls ("update stations" and the like); it just didn't work to send out updates.


That is the way mine works. The TCU can handle station updates and some data to Nissan even when it fails to respond to remote requests and fails to send charge notifications. I had a dead 12-volt battery in January (exactly one month after TCU replacement) and have only needed to pull the fuse twice since then to keep everything working. The 12-volt battery was OK even after being parked for over two weeks at the airport with the Bluetooth unit plugged in to the OBDII port (forgot to unplug it when I parked).
Gerry
Silver LEAF 2011 SL rear ended (totaled) by in-attentive driver 1/4/2015 at 50,422 miles
Silver LEAF 2015 SL purchased 2/7/2015

notnami
Posts: 3
Joined: Sun Sep 10, 2017 10:18 am
Delivery Date: 10 Sep 2017

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Sun Sep 10, 2017 10:23 am

I apologise if that has already been addressed. Does pulling fuse 34 solve the yellow light/P3131 problem? We have '13 SV with the new TCU installed a couple of months ago. We previously had the problem where the app stopped updating, and pulling the fuse fixed that. However, today the app stopped updating again, and the next time we turned on the car the yellow light turned on, with LeafSpy reporting DTC P3131. I read the posts where someone reportedly cleared the error light by stopping data transmission, but does that still allow you to use NissanConnect to query charging status?

User avatar
Stanton
Forum Supporter
Posts: 1944
Joined: Thu Feb 03, 2011 10:56 am
Delivery Date: 01 Sep 2011
Leaf Number: 7458
Location: Plano, TX
Contact: Website Twitter

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Sun Sep 10, 2017 10:50 am

notnami wrote:I apologise if that has already been addressed. Does pulling fuse 34 solve the yellow light/P3131 problem? We have '13 SV with the new TCU installed a couple of months ago. We previously had the problem where the app stopped updating, and pulling the fuse fixed that. However, today the app stopped updating again, and the next time we turned on the car the yellow light turned on, with LeafSpy reporting DTC P3131. I read the posts where someone reportedly cleared the error light by stopping data transmission, but does that still allow you to use NissanConnect to query charging status?


Lack of TCU communication and the "yellow light" are related.
Pulling the fuse should fix both after re-start.
I've had to pull the fuse a couple of times in the last week (which is unusual); it's not like you can "break" it (in a way it's already "broken").
2011 Blue Ocean SV w/floor mats & window tint
12v LiFePO4 battery & FIAMM 74100 horns
Wet Okole seat covers (front)
Tor's low-power heater mod
2013 sun visor
3G modem upgrade
L2 EVSE Upgrade
Battery Pack replaced (Rev E) @51 months and 41k miles

notnami
Posts: 3
Joined: Sun Sep 10, 2017 10:18 am
Delivery Date: 10 Sep 2017

Re: NissanConnect EV / Telematics Hardware Update, for the post-2G world

Sun Sep 10, 2017 1:14 pm

Well, the warning light went away and the app started working again without any action on my part. I hope it stays this way.

Return to “Range / Efficiency / Carwings”