Page 1 of 1

iPod recognized by radio but no audio?----Fix found!!

Posted: Wed Mar 06, 2013 7:30 pm
by MrIanB
Guys,


iPod always played flawless. Came back from gym and now I can see the songs, select any but no audio coming out. Changed sources and Bluetooth , radio, cd all play with sound. I tried unplugging USB fom deck and iPod, reconnect and still get no audio. Powered car off and back on and still no audio sound. I plugged the iPod to headphones and I can hear sound as normal.

Is something wrong with deck or does anyone have any other suggestions?

Tia,

Ian B

Re: iPod recognized by radio but no audio?

Posted: Wed Mar 06, 2013 10:01 pm
by walterbays
MrIanB wrote:does anyone have any other suggestions?
Yes. I don't know if they're good suggestions though.

Check whether ipod may have different volume controls for playback over usb versus playback over headphones. Maybe volume on the ipod is turned down to zero.

Check whether Leaf plays music okay from mp3 files on a plain old usb storage stick

Check whether Leaf plays music from your ipod connected through aux port rather than usb

Re: iPod recognized by radio but no audio?

Posted: Wed Mar 06, 2013 11:27 pm
by MrIanB
walterbays wrote:
MrIanB wrote:does anyone have any other suggestions?
Yes. I don't know if they're good suggestions though.

Check whether ipod may have different volume controls for playback over usb versus playback over headphones. Maybe volume on the ipod is turned down to zero.

Check whether Leaf plays music okay from mp3 files on a plain old usb storage stick

Check whether Leaf plays music from your ipod connected through aux port rather than usb


Thanks Walter, will test tomorrow. Funny thing it was working fine since day one and have not removed it in months. It just sits plugged in w the iPod stock white cale connector. Will report back tomorrow.

Ian B

Re: iPod recognized by radio but no audio?

Posted: Wed Mar 06, 2013 11:44 pm
by vrwl
Ian, hope you figure it out. I use my iPod connected with the same white USB wire as you do. I've had one instance where it got a bit funky once (I took it out to update the iPod with more music) and when I plugged it in, it didn't recognize it immediately. So I did the same things you mentioned, turned off the car, unplugged it, plugged it back in, turned the car back on, and then it was ok. I also occasionally have an issue with it displaying the song/album info. Can't seem to figure out any pattern to that, most days it displays ok, but every now and then it won't.

Re: iPod recognized by radio but no audio?

Posted: Thu Mar 07, 2013 6:29 am
by adspguy
You might try rebooting the iPod. http://support.apple.com/kb/ht1320.

Re: iPod recognized by radio but no audio?

Posted: Thu Mar 07, 2013 7:41 am
by Stanton
When this happens to me, it's always the iPhone/iPod's fault. Go into the BT menu (on the phone) and select/force the car connection again. It should be fine (until the next time it happens). :shock:

Re: iPod recognized by radio but no audio?

Posted: Thu Mar 07, 2013 7:45 am
by MrIanB
adspguy wrote:You might try rebooting the iPod. http://support.apple.com/kb/ht1320.



Thanks for the tip. Rebooting the ipod touch did the trick and now i have sound again. Woohoooooo!!!!

Ian B

Re: iPod recognized by radio but no audio?----Fix found!!

Posted: Mon Jun 11, 2018 7:05 pm
by happygaijin
I know it's been awhile, but I ran into this problem after just buying a used 2015 Leaf and struggled for a few days until I discovered the answer.

TL;DR - Try all of the above suggestions, if it still doesn't work, then make sure your iOS Music app is installed and has at least one music file.

My wife and I both have iPhone X on iOS 11.4. Hers worked in the Leaf and mine didn't. I tried all of the suggestions. Then I noticed that when it does work with hers, it first says "Reading Files". Even though we weren't using the Music files on the iPhone - we were using Spotify. The Nissan looks for the files first. I didn't have any files on mine, but she does. So hers ends up going to the screen where you can select Playlist, Songs, Artists, etc, and mine would go to "No Songs" and then I couldn't use any audio. So I tried putting one song into my Music app - and voila - it worked just like hers. I could use Spotify and Maps audio after that.