Yodrak
Posts: 491
Joined: Thu Jun 17, 2010 7:01 am
Delivery Date: 12 Mar 2015
Leaf Number: 402954
Location: St Louis, MO

Re: How To: Backup camera for S model with OE parts

Fri Jan 06, 2017 1:28 pm

I'm a little bit confused here, I want to be sure that we are talking about the same harness and the correct designation for that harness.

The correct hatch harness is 24052-3NF0C. If you are using the 'B' hatch harness there won't be a connector for the camera.

The correct hatch-to-body harness is 24051-3NF0B. If you are using the 'C' hatch-to-body harness there won't be a 3rd wire at the grounding lug.

If you are using the correct harnesses then you problem is most likely the same as some others have had - the front-to-rear harness does not have the five camera wires in it. In the rear pillar look carefully at the large connector on the front-to-rear harness and its mating connector on the hatch-to-body harness. In the center section, are there 5 more male pins on the hatch-to-body piece of the connector than there are female receptors on the front-to-back piece of the connector? The holes will be there, but no wires going in or metal receptors inside the front-to-back piece of the connector.

If I remember correctly, there are two rows with six positions each in the center section of the connector. Looking at the connector as it is mounted on the sheet metal, the six positions on the right (two rows of three) will have wires coming in from both sides - from the hatch-to-body harness at the top and from the front-to-rear harness from the bottom. On the left, there will be the five camera wires coming from the hatch-to-body harness at the top. Are there five matching wires at the bottom coming up from the front-to back harness? If not, that's your problem, those five wires are missing.

Again, I'm talking about the center section of the connector. There are additional wires at the right and left sides of the connector, don't get confused by them. I'm talking about the right and left sides of the center section of the connector.

Brayne wrote:Thank You. I DID get the B. All the plugs matched up with the B and it "appeared" to have the proper wiring but obviously it is not working. I will check the pins for sure. I may just buy the C and have a go at it.
Khun Yodrak
2013 SL

Brayne
Posts: 6
Joined: Sun Nov 20, 2016 7:53 am
Delivery Date: 23 Nov 2016
Leaf Number: 401995

Re: How To: Backup camera for S model with OE parts

Sat Jan 07, 2017 7:30 am

Thank you for your help. I have triple checked my part numbers. I have;

Harness body/hatch - 24051-3NF0B
Harness Back Dr - 24052-3NF0B

The Camera does in fact plugin as you would expect it to. (2 females in that section of the harness, 1 for the hatch and 1 for the camera). I think, based on your advice, I need to take it apart again and check the pin patterns to see what's going on. Perhaps the (Back Door harness 3NF0B vs 3NF0C) have slightly different pin patterns? Or maybe I just got "lucky" and they didn't run the wires from the front to rear in my car. I'll post final results for anyone else that may want or need it.

Scratching my head.
1st LEAF pre-owned
'13 SL The Black Pearl
34k - 11 bars

Yodrak
Posts: 491
Joined: Thu Jun 17, 2010 7:01 am
Delivery Date: 12 Mar 2015
Leaf Number: 402954
Location: St Louis, MO

Re: How To: Backup camera for S model with OE parts

Sat Jan 07, 2017 8:04 am

Sorry I couldn't be of more help. My SL came with the C hatch harness, so I can't comment on what might be different between the B and C harnesses.

One thing for sure, you do need to confirm whether or not you have the 5 camera wires in the harness that runs from the rear door pillar to the front of the car.

I wish you good luck.

Brayne wrote:Thank you for your help. I have triple checked my part numbers. I have;

Harness body/hatch - 24051-3NF0B
Harness Back Dr - 24052-3NF0B

The Camera does in fact plugin as you would expect it to. (2 females in that section of the harness, 1 for the hatch and 1 for the camera). I think, based on your advice, I need to take it apart again and check the pin patterns to see what's going on. Perhaps the (Back Door harness 3NF0B vs 3NF0C) have slightly different pin patterns? Or maybe I just got "lucky" and they didn't run the wires from the front to rear in my car. I'll post final results for anyone else that may want or need it.

Scratching my head.
Khun Yodrak
2013 SL

vashwood
Posts: 9
Joined: Sun Jan 22, 2017 12:29 pm
Delivery Date: 22 Jan 2017

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 12:31 pm

I'm about to attempt this on my 2013 SV.

I want to double-check something. When I look at the driver-side kick panel, I see two connectors side by side. I assume the one on the left is B23 and the one to the right is M21?

medtech1
Posts: 48
Joined: Thu Jul 21, 2016 6:57 am
Delivery Date: 21 Jul 2016

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 12:57 pm

This is the M21.

http://redhat.systems/leaf/IMG_1598.JPG

I cut the nylon strap and pulled it out to get more access to the wires. (be sure to disconnect the 12v battery first).

Just for reference, this is the pinout of M21... not all the pins are used:

http://redhat.systems/leaf/m21-pinout.png

I assume you have docs on which wire from the camera go to where?

Brayne
Posts: 6
Joined: Sun Nov 20, 2016 7:53 am
Delivery Date: 23 Nov 2016
Leaf Number: 401995

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 1:31 pm

medtech1 wrote:This is the M21.

http://redhat.systems/leaf/IMG_1598.JPG

I cut the nylon strap and pulled it out to get more access to the wires. (be sure to disconnect the 12v battery first).

Just for reference, this is the pinout of M21... not all the pins are used:

http://redhat.systems/leaf/m21-pinout.png

I assume you have docs on which wire from the camera go to where?



I am working on it right now. Have all the panels off. Have just grounded Pin 7 from M21 and see the black screen with yellow guide lines.

Pin 7 = Sense - Ground
Pin 8 = Shield - to camera color?
Pin 9 = Video - to camera color?
Pin 24 = + Volt supply - to camera color?
Pin 25 = Negative supply - to camera color?

I am so close I can taste it. any help would be fantastic.
1st LEAF pre-owned
'13 SL The Black Pearl
34k - 11 bars

vashwood
Posts: 9
Joined: Sun Jan 22, 2017 12:29 pm
Delivery Date: 22 Jan 2017

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 1:36 pm

medtech1 wrote:This is the M21.

http://redhat.systems/leaf/IMG_1598.JPG

I cut the nylon strap and pulled it out to get more access to the wires. (be sure to disconnect the 12v battery first).

Just for reference, this is the pinout of M21... not all the pins are used:

http://redhat.systems/leaf/m21-pinout.png

I assume you have docs on which wire from the camera go to where?


Thanks! I'm comparing your photo of the M21 to what I have. I guess it looks like I don't have the cables from AV?

This is my left connector (M21)
https://drive.google.com/open?id=0B72qQeKA6G0IVGo0R1l1b3JfUG83YU4zbDI2WnNzWmVRRXlV

And this is the one on the right (assuming this is B3?)
https://drive.google.com/open?id=0B72qQeKA6G0IMEswbFNEeUgxVXFuN1p0TXBSTlQ0Z3N4dk9N

I had the following notes for the wiring
M21 Pin 7 to chassis ground
M21 Pin 24 to Camera Red
M21 Pin 25 to Camera Black
M21 Pin 9 to Camera Yellow
M21 Pin 8 to Camera White.

medtech1
Posts: 48
Joined: Thu Jul 21, 2016 6:57 am
Delivery Date: 21 Jul 2016

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 1:38 pm

The answer is previously in this thread:

viewtopic.php?f=37&t=12617&start=60

Brayne
Posts: 6
Joined: Sun Nov 20, 2016 7:53 am
Delivery Date: 23 Nov 2016
Leaf Number: 401995

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 1:41 pm

vashwood wrote:
medtech1 wrote:This is the M21.

http://redhat.systems/leaf/IMG_1598.JPG

I cut the nylon strap and pulled it out to get more access to the wires. (be sure to disconnect the 12v battery first).

Just for reference, this is the pinout of M21... not all the pins are used:

http://redhat.systems/leaf/m21-pinout.png

I assume you have docs on which wire from the camera go to where?


Thanks! I'm comparing your photo of the M21 to what I have. I guess it looks like I don't have the cables from AV?

This is my left connector (M21)
https://drive.google.com/open?id=0B72qQeKA6G0IVGo0R1l1b3JfUG83YU4zbDI2WnNzWmVRRXlV

And this is the one on the right (assuming this is B3?)
https://drive.google.com/open?id=0B72qQeKA6G0IMEswbFNEeUgxVXFuN1p0TXBSTlQ0Z3N4dk9N

I had the following notes for the wiring
M21 Pin 7 to chassis ground
M21 Pin 24 to Camera Red
M21 Pin 25 to Camera Black
M21 Pin 9 to Camera Yellow
M21 Pin 8 to Camera White.


looks like you don't have the wiring coming from the dash to M21.
1st LEAF pre-owned
'13 SL The Black Pearl
34k - 11 bars

medtech1
Posts: 48
Joined: Thu Jul 21, 2016 6:57 am
Delivery Date: 21 Jul 2016

Re: How To: Backup camera for S model with OE parts

Sun Jan 22, 2017 1:46 pm

Vashwood.. I think you're right... wires are missing from the M21.

Yours on the left, mine on the right

http://redhat.systems/leaf/Screen%20Shot%202017-01-22%20at%2012.42.31%20PM.png

what model Leaf is yours? S or SV?

Return to “Accessories / Mods”