cwerdna
Gold Member
Posts: 7071
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: Leaf Spy Lite

Mon Jul 04, 2016 5:05 pm

dhanson865 wrote:Well I guess it was just a fluke. I went down and paired the bluetooth on my android 6.x phone and leafspy connected no problem.

Yep. I've been using a Nexus 5X w/Android 6.x.x (now 6.0.1) for a few months w/Leaf Spy Pro over Bluetooth.

I had to go to this phone as my work requires us to use either the Nexus 5X or 6P if we want access to certain corporate resources. So, I had to turn in my Samsung Galaxy S6 that was working fine w/it (and was still on Lollipop aka 5.x.x). Before that, was using a Galaxy S4. The BT dongle has been the same one the whole time.

'13 blue Leaf SV w/premium package (owned)
'13 blue Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

Catflyer
Posts: 15
Joined: Sun Jul 03, 2016 6:15 pm
Location: Christchurch, New Zealand

Re: Leaf Spy Lite

Mon Jul 04, 2016 6:50 pm

cwerdna wrote:
dhanson865 wrote:Well I guess it was just a fluke. I went down and paired the bluetooth on my android 6.x phone and leafspy connected no problem.

Yep. I've been using a Nexus 5X w/Android 6.x.x (now 6.0.1) for a few months w/Leaf Spy Pro over Bluetooth.

I had to go to this phone as my work requires us to use either the Nexus 5X or 6P if we want access to certain corporate resources. So, I had to turn in my Samsung Galaxy S6 that was working fine w/it (and was still on Lollipop aka 5.x.x). Before that, was using a Galaxy S4. The BT dongle has been the same one the whole time.


So you can get the menu to come up ok by tapping on the Soft Menu icon at the top right?

cwerdna
Gold Member
Posts: 7071
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: Leaf Spy Lite

Mon Jul 04, 2016 6:52 pm

Catflyer wrote:
cwerdna wrote:
dhanson865 wrote:Well I guess it was just a fluke. I went down and paired the bluetooth on my android 6.x phone and leafspy connected no problem.

Yep. I've been using a Nexus 5X w/Android 6.x.x (now 6.0.1) for a few months w/Leaf Spy Pro over Bluetooth.

I had to go to this phone as my work requires us to use either the Nexus 5X or 6P if we want access to certain corporate resources. So, I had to turn in my Samsung Galaxy S6 that was working fine w/it (and was still on Lollipop aka 5.x.x). Before that, was using a Galaxy S4. The BT dongle has been the same one the whole time.


So you can get the menu to come up ok by tapping on the Soft Menu icon at the top right?

Yes. Tapping on that (using Pro version) yields the 2 rows of buttons: Select OBDII, View Trip Log, Settings, About & Help, Exit.

The phone came w/the factory image and I had to apply a boatload of Google's updates (all delivered to recent Nexus phones). It's not rooted, not running CyanogenMod or anything like that.

'13 blue Leaf SV w/premium package (owned)
'13 blue Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

Catflyer
Posts: 15
Joined: Sun Jul 03, 2016 6:15 pm
Location: Christchurch, New Zealand

Re: Leaf Spy Lite

Mon Jul 04, 2016 8:22 pm

cwerdna wrote:
Catflyer wrote:
cwerdna wrote:Yep. I've been using a Nexus 5X w/Android 6.x.x (now 6.0.1) for a few months w/Leaf Spy Pro over Bluetooth.

I had to go to this phone as my work requires us to use either the Nexus 5X or 6P if we want access to certain corporate resources. So, I had to turn in my Samsung Galaxy S6 that was working fine w/it (and was still on Lollipop aka 5.x.x). Before that, was using a Galaxy S4. The BT dongle has been the same one the whole time.


So you can get the menu to come up ok by tapping on the Soft Menu icon at the top right?

Yes. Tapping on that (using Pro version) yields the 2 rows of buttons: Select OBDII, View Trip Log, Settings, About & Help, Exit.

The phone came w/the factory image and I had to apply a boatload of Google's updates (all delivered to recent Nexus phones). It's not rooted, not running CyanogenMod or anything like that.


Thanks for that. Maybe the issue is just with Leaf Spy Lite. I will get Leaf Spy Pro and try it.

Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy Lite

Tue Jul 05, 2016 9:53 am

Catflyer wrote:
cwerdna wrote:
Catflyer wrote:
So you can get the menu to come up ok by tapping on the Soft Menu icon at the top right?

Yes. Tapping on that (using Pro version) yields the 2 rows of buttons: Select OBDII, View Trip Log, Settings, About & Help, Exit.

The phone came w/the factory image and I had to apply a boatload of Google's updates (all delivered to recent Nexus phones). It's not rooted, not running CyanogenMod or anything like that.


Thanks for that. Maybe the issue is just with Leaf Spy Lite. I will get Leaf Spy Pro and try it.

Please report back if LeafSpy Pro works for you. It is compiled with a much newer version of B4A so that might make a difference. If it does then I will release an updated version of LeafSpy Lite using the newer compiler.

Catflyer
Posts: 15
Joined: Sun Jul 03, 2016 6:15 pm
Location: Christchurch, New Zealand

Re: Leaf Spy Lite

Tue Jul 05, 2016 2:19 pm

Turbo3 wrote:
Catflyer wrote:
cwerdna wrote:Yes. Tapping on that (using Pro version) yields the 2 rows of buttons: Select OBDII, View Trip Log, Settings, About & Help, Exit.

The phone came w/the factory image and I had to apply a boatload of Google's updates (all delivered to recent Nexus phones). It's not rooted, not running CyanogenMod or anything like that.


Thanks for that. Maybe the issue is just with Leaf Spy Lite. I will get Leaf Spy Pro and try it.

Please report back if LeafSpy Pro works for you. It is compiled with a much newer version of B4A so that might make a difference. If it does then I will release an updated version of LeafSpy Lite using the newer compiler.


I have installed LeafSpy Pro and the Soft Menu works fine on the Samsung S6. Looks like it is only the LeafSpy Lite build that is effected. Now I just have to find a Leaf to buy!

One thing I did notice as I was changing the Settings on LeafSpy Pro - when you change the units between "Feet,mile,mph" and "Meters,km,km/h" the Range setting is automatically changed to the correct unit but the Trip Distance is not. Exiting out of the Settings and going back in the Trip Distance unit is then correct.

Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy Lite

Tue Jul 05, 2016 2:22 pm

Catflyer wrote:
Turbo3 wrote:
Catflyer wrote:
Thanks for that. Maybe the issue is just with Leaf Spy Lite. I will get Leaf Spy Pro and try it.

Please report back if LeafSpy Pro works for you. It is compiled with a much newer version of B4A so that might make a difference. If it does then I will release an updated version of LeafSpy Lite using the newer compiler.


I have installed LeafSpy Pro and the Soft Menu works fine on the Samsung S6. Looks like it is only the LeafSpy Lite build that is effected. Now I just have to find a Leaf to buy!

One thing I did notice as I was changing the Settings on LeafSpy Pro - when you change the units between "Feet,mile,mph" and "Meters,km,km/h" the Range setting is automatically changed to the correct unit but the Trip Distance is not. Exiting out of the Settings and going back in the Trip Distance unit is then correct.

Thanks for reporting and finding the bug. Should be easy to fix.

brycenesbitt
Posts: 85
Joined: Sun Jan 31, 2016 8:48 pm
Delivery Date: 01 Feb 2016

Re: Leaf Spy Lite

Sun Aug 14, 2016 8:33 am

Is the LELink OBD-II bluetooth (http://www.ksolution.org/outdoor/enginelink.html) supported by Leaf Spy/Lite/Pro?

I purchased and have used Leaf Spy Pro on iOS, but have just changed phones. When I bring up Leaf Spy Lite
it immediately asks to pair with the bluetooth device, which is not done for Bluetooth Low Energy devices.

TimLee
Posts: 2810
Joined: Thu Jan 20, 2011 9:40 am
Delivery Date: 17 May 2011
Leaf Number: 2026
Location: Chattanooga, TN

Re: Leaf Spy Lite

Sun Aug 14, 2016 8:39 am

^^^ I don't think Jim has implemented support for the new low energy devices yet on Android versions.
He plans to but has been busy working on Tesla versions.

Tim Lee
Chattanooga, TN

Man. Date: 03/10/11, VIN # 2026
Delivered 05-17-2011
Blue Ocean, 2011 SL-eTec

Waldemar
Posts: 1
Joined: Sat Nov 26, 2016 12:16 pm
Delivery Date: 21 Jun 2016
Leaf Number: 050435
Location: Oslo, Norway

Re: Leaf Spy Lite

Sat Nov 26, 2016 12:22 pm

Hello everyone, I have tried Leaf Spy Lite with GoPoing BT1A (2.1 device, link bellow). Found the dongle in some box, worked fine on my Prius 2nd gen.

http://gopointtech.com/product/bt1a-for-apple-android/

Pairing went fine with both Samsung Galaxy S3 (on KitKat) and Galaxy Tab S on Marshmallow. But that was it, few times "Broken Pipe", SOC is 0% all the time. I guess it is because of BT 2.1, can someone confirm or give some advice? Thx in advance, best regards from Norway

Return to “LEAF CANBus”