ClarD
Posts: 16
Joined: Mon May 02, 2016 8:17 pm
Delivery Date: 06 Apr 2016

Re: Leaf Spy and Leaf Spy Pro

Thu Apr 20, 2017 12:00 pm

In the http://www.electricvehiclewiki.com/Leaf_Spy_Pro it says
"calibrate the 12 volt battery voltage", but I can't find that. in my LeafSpy Pro v0.39.37
A DMM shows 12.28v while LeafSpy shows 12.88

webfootguy
Posts: 28
Joined: Thu Oct 21, 2010 4:32 pm
Delivery Date: 25 Mar 2016
Location: Portland, OR

Re: Leaf Spy and Leaf Spy Pro

Thu Apr 20, 2017 12:32 pm

Slow transfer mode fixed it for this adapter. Thanks for the hint. I can still do a trace without the slow transfer mode if you want.

Turbo3 wrote:
webfootguy wrote:I am on Android 6.0 on a LG G4 on T-Mobile and my Leaf Spy Pro just upgraded from v0.38 to v0.39. Now my adapter which worked fine on previous releases won't work. The adapter I am using is: https://smile.amazon.com/gp/product/B00PJPHEBO.

Any suggestions on how to debug the problem or how to go back to version 38?

What status and colors are you seeing in the bottom right corner status box?

You could also try turning on the slow transfer mode on the Settings/Options panel and see it that helps.

I need an ELM trace to see what is going on. See bottom of the built-in help for how to do it.
2016 SL with Premium Package 3 year lease on 03-25-2016.

Turbo3
Gold Member
Posts: 1749
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Thu Apr 20, 2017 2:36 pm

ClarD wrote:In the http://www.electricvehiclewiki.com/Leaf_Spy_Pro it says
"calibrate the 12 volt battery voltage", but I can't find that. in my LeafSpy Pro v0.39.37
A DMM shows 12.28v while LeafSpy shows 12.88

That is old documentation. The 12 volts is now read from the Leaf directly.

It is the 12 volts as seen and measured by the VCM ECU.

Turbo3
Gold Member
Posts: 1749
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Thu Apr 20, 2017 2:40 pm

webfootguy wrote:Slow transfer mode fixed it for this adapter. Thanks for the hint. I can still do a trace without the slow transfer mode if you want.

Turbo3 wrote:
webfootguy wrote:I am on Android 6.0 on a LG G4 on T-Mobile and my Leaf Spy Pro just upgraded from v0.38 to v0.39. Now my adapter which worked fine on previous releases won't work. The adapter I am using is: https://smile.amazon.com/gp/product/B00PJPHEBO.

Any suggestions on how to debug the problem or how to go back to version 38?

What status and colors are you seeing in the bottom right corner status box?

You could also try turning on the slow transfer mode on the Settings/Options panel and see it that helps.

I need an ELM trace to see what is going on. See bottom of the built-in help for how to do it.

I would be interested in seeing what is up with the Cyanogenmod mode and exactly why it did not help. It should result in very slow transfers so one of my hang timers might be the problem. An ELM trace would help.

Turbo3
Gold Member
Posts: 1749
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Thu Apr 20, 2017 2:43 pm

ClarD wrote:
Turbo3 wrote:
IIama wrote:


I don't recall enabling the Braking & Motor Monitor, but it was causing my Konnwei KW903 to freeze when I visited that screen.
I disabled that feature, and the KW903 half height seems to be a good unit. It connects and holds connection much better than my VGate ELM 327 full height unit. I never used LeafSpy while driving, because I knocked the full height dongle out of the socket once.

Will this feature be made to work for dongles that currently freeze?

2013 Leaf S, Android 7.0 Samsung Galaxy S7, LeafSpy Pro v0.39.97, Konnwei KW903 from Amazon "Best Compu".

I might have time later this year to do more testing to see if it can be made more stable or I might use a different approach that does not have this problem.

ClarD
Posts: 16
Joined: Mon May 02, 2016 8:17 pm
Delivery Date: 06 Apr 2016

Re: Leaf Spy and Leaf Spy Pro

Fri Apr 21, 2017 1:48 pm

With version v0.39.97 I see the new
Motor Temp
Inverter 2 Temp
Inverter 4 Temp

Motor Temp seems to vary during a drive from 71 to 78, with a rise after stopping to 82,
The two inverter temperatures stay at 40, always.

2013 Leaf S, Android 7.0 Samsung Galaxy S7, LeafSpy Pro v0.39.97, Konnwei KW903 from Amazon "Best Compu".

Turbo3
Gold Member
Posts: 1749
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Fri Apr 21, 2017 7:29 pm

ClarD wrote:With version v0.39.97 I see the new
Motor Temp
Inverter 2 Temp
Inverter 4 Temp

Motor Temp seems to vary during a drive from 71 to 78, with a rise after stopping to 82,
The two inverter temperatures stay at 40, always.

2013 Leaf S, Android 7.0 Samsung Galaxy S7, LeafSpy Pro v0.39.97, Konnwei KW903 from Amazon "Best Compu".

Starting with the 2013 model year Nissan changed some of the response formats. I will need to check if the Inverter temps were changed as 40 with a motor temp in the 71 to 82 sounds wrong.

Return to “LEAF CANBus”