Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

iOS LeafSpy Pro Support

Fri Feb 13, 2015 4:21 pm

LeafSpy Pro is now available from the Apple App Store.

Use this link to go directly to the App Store listing for Leaf Spy Pro:
https://itunes.apple.com/us/app/leafspy-pro/id967376861?mt=8

Use this thread to report problems and ask questions about the iOS version of LeafSpy Pro.

Runs only on iOS version 7.1 or greater. Requires a WiFi OBDII Adapter to connect to your Leaf.
Last edited by Turbo3 on Thu Mar 19, 2015 5:17 pm, edited 2 times in total.

Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Fri Feb 13, 2015 4:21 pm

Instructions almost fit on one iPad screen. I may cut and paste later so there is no overlap here.

Image Image
Last edited by Turbo3 on Fri Feb 13, 2015 8:39 pm, edited 1 time in total.

Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Fri Feb 13, 2015 8:07 pm

Helpful tips will go here.

BooKittyLeaf
Posts: 86
Joined: Mon Jan 12, 2015 11:11 pm
Delivery Date: 22 Jan 2015
Leaf Number: 000000
Location: Phoenix, AZ

Re: iOS LeafSpy Pro Support

Mon Feb 16, 2015 9:39 pm

Just got my Invite to the Beta & downloaded it.

I have been using Leaf Stat

LeafSpy opened right up & grabbed my OBD2 WiFi signal after about 10 sec initially. Now it grabs the WiFi right away when opened.

Works with the same WiFi settings as LeafStat and provides so much more info, as well a alarms for low tire pressure!
I can actually use them both without reseting anything

Excited to finally have it on ios - will report back after I paly around with it for a while.
2015 SV, LED & QC, Black / Black. Mfg Date 08,22,14

coloradoren
Posts: 9
Joined: Wed Jan 14, 2015 2:17 pm
Delivery Date: 25 Jan 2015
Location: Boulder, CO

Re: iOS LeafSpy Pro Support

Tue Feb 17, 2015 1:11 pm

Invite and download seemed to work fine. Now I'm just waiting on my adapter to come from Amazon...
2012 SL in Electric Blue

finman100
Posts: 276
Joined: Thu Sep 20, 2012 10:42 am
Delivery Date: 06 Jun 2014
Location: Albany, OR

Re: iOS LeafSpy Pro Support

Tue Feb 17, 2015 2:30 pm

Really good stuff on LeafSpy! Got the beta downloaded and am testing on an iPad air 1 and an iPhone 5s, both running iOS 8.1.3.

I have this adapter http://www.ebay.com/itm/Super-Mini-ELM327-WiFi-with-Switch-For-IPhone-OBD2-OBD-Scanner-Code-Reader-Tool-/151352239350

Been using it with LeafStat for 3 months. Love it so far.

LeafSpy has ALOT going on, so I will play with some of the features. So far it works fine as far as I know, giving me all the info that LeafStat has plus the individual cell pairs and graphs. What is and how do you set up the elevation thing? Only 3 temp sensors for the battery (sensors 1, 2, and 4 show up)?

More as I figure it out! Great stuff. Great to have another app to show these geeky numbers.

Curt
Last edited by finman100 on Tue Feb 17, 2015 6:32 pm, edited 1 time in total.
Albany, Oregon
2014 Silver SV with charge/LED package. June 2014, I'm in the EV game!
40,200 miles
18.5 kWh on 100% charge (54-ish Ah)
4.2 miles/kWh average
Best trip: all of 'em. They're all no-gas!

Turbo3
Gold Member
Posts: 1823
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Tue Feb 17, 2015 2:56 pm

Only model yeras 2011/2012 have 4 battery temperature sensors. All others have only 3.

Elevation should be automatic when you start driving although the first time you use it iOS will probably ask your permission to allow Leaf Spy Pro access to location data.

CWO4Mann
Gold Member
Posts: 429
Joined: Thu Jul 28, 2011 8:12 am
Delivery Date: 11 Dec 2011
Leaf Number: 1567
Location: Brentwood, TN
Contact: Facebook

Re: iOS LeafSpy Pro Support

Tue Feb 17, 2015 4:45 pm

Turbo3 wrote:Use this thread to report problems and ask questions about the iOS version of LeafSpy Pro.

Runs only on iOS version 7.1 or greater. Requires a WiFi OBDII Adapter to connect to your Leaf.

This post will be updated when LeafSpy Pro is available for download from the App Store

This thread is for support questions and help. If you have new feature requests those should go in the development discussion thread along with any beta tester comments.



You are a Star! Thank you
Ira est potens et pertinax.
Study History - Know the Future
N4CVX; ex-VP2EHF; ex-DA1BB; ex-KR6DEM
2012 SL Glacier Pearl VIN: 1567 Delivered 12-11-2011
Cool Springs Nissan, Franklin, TN

BooKittyLeaf
Posts: 86
Joined: Mon Jan 12, 2015 11:11 pm
Delivery Date: 22 Jan 2015
Leaf Number: 000000
Location: Phoenix, AZ

Re: iOS LeafSpy Pro Support

Tue Feb 17, 2015 6:31 pm

finman100 wrote: Only 3 temp sensors for the battery (sensors 1, 2, and 4 show up)?

Depends on what year Leaf you have. Earlier Leafs had 4 temp sensors, later ones only have 3. My 2015 has 3.
Dont know what year they dropped a sensor, but if your showing 1,2,4 like me, yours has 3 sensors & is functioning correctly
2015 SV, LED & QC, Black / Black. Mfg Date 08,22,14

User avatar
Nubo
Posts: 4417
Joined: Fri May 28, 2010 11:01 am
Delivery Date: 31 Oct 2014
Location: Vallejo, CA

Re: iOS LeafSpy Pro Support

Wed Feb 18, 2015 10:13 am

All seemed to be working well last night. Tried the various screens including service screens. I had graphed a charge session for about 15 minutes or so. I saved the .csv, shut everything down, including closing the app. I downloaded the .csv via iTunes on my Mac.

This morning I got in the car and started the app. It came up briefly but there seemed to be a flash and I was returned to the iPhone home screen. I tapped the icon again and the same thing happened. I thought the app had crashed but it was still actually running in the background. I selected it from the running apps instead of the app icon, and it came up.

Most things seemed to be working, but the graph would not update. It is still showing last night's charge recording. Not sure how to erase the graph and start with a new one, or at least continue graphing new values. I see options in the settings pertaining to reset "manually","automatically", "drive and charge", etc... But I tried the different ones, turning the car on and off and the old graph remains and doesn't update. I left the app running as I drove this morning but the old graph remains unchanged. The text info on that screen does update the SOC and GIDs...

Now that I am not connected to the WiFi, I can close the app and restart it from the icon just fine.
I noticed you're still working with polymers.

Return to “LEAF CANBus”