vecsy90
Posts: 1
Joined: Fri Dec 22, 2017 9:37 am
Delivery Date: 25 Nov 2017

Re: iOS LeafSpy Pro Support

Fri Dec 22, 2017 9:54 am

Hi All,
I would appreciate a little help please. I just bought my Leaf less than a month ago. Prior to the purchase I ordered an OBD II Wifi adapter for my iPhone 5S to be able to check SoH when I am buying the car. I bought it from ebay and it said it is iOS compatible. Obviously it wasn't as it didn't work. I also paid £20 and downloaded the LeafSpy Pro from app store. I am not sure about the issue, but when I connect the wifi adapter and log into LeafSpy (doing everything as per as the instructions within LeafSpy Pro app) it says "retry ELM 11" in the bottom right corner and it is in yellow colour. I still bought the car as it was a good deal (hopefully) but I still would like to check SoH, so I have ordered another adapter from ebay. Unfortunately this one does the same. So as it is the second adapter with the same issue it makes me think that I am doing something wrong.
I try to link in the adapters from ebay:
https://www.ebay.co.uk/itm/WiFi-Wireles ... 2748.l2649

https://www.ebay.co.uk/itm/Mini-WiFi-EL ... 2749.l2649

I would appreciate any help.

Thanks,

TimJolly
Posts: 1
Joined: Fri Dec 22, 2017 9:48 am
Delivery Date: 22 Dec 2017
Leaf Number: 039022

Re: iOS LeafSpy Pro Support

Fri Dec 22, 2017 10:05 am

Well, I have been using Leaf Spy for the last six months -- Carista to iPhone 6s. I downloaded Leaf Spy 1.6.28 last night, and today the iPhone cannot make a connection, no matter how hard it tries!

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Fri Dec 22, 2017 1:09 pm

vecsy90 wrote:Hi All,
I would appreciate a little help please. I just bought my Leaf less than a month ago. Prior to the purchase I ordered an OBD II Wifi adapter for my iPhone 5S to be able to check SoH when I am buying the car. I bought it from ebay and it said it is iOS compatible. Obviously it wasn't as it didn't work. I also paid £20 and downloaded the LeafSpy Pro from app store. I am not sure about the issue, but when I connect the wifi adapter and log into LeafSpy (doing everything as per as the instructions within LeafSpy Pro app) it says "retry ELM 11" in the bottom right corner and it is in yellow colour. I still bought the car as it was a good deal (hopefully) but I still would like to check SoH, so I have ordered another adapter from ebay. Unfortunately this one does the same. So as it is the second adapter with the same issue it makes me think that I am doing something wrong.
I try to link in the adapters from ebay:
https://www.ebay.co.uk/itm/WiFi-Wireles ... 2748.l2649

https://www.ebay.co.uk/itm/Mini-WiFi-EL ... 2749.l2649

I would appreciate any help.

Thanks,

Can you take an ELM trace and send it to me? See bottom of Help file for how to do it. I assume you have the Leaf ON with the dash gauges active not just in ACC mode and you did not receive any warning message about the Adapter not supporting the needed commands.

The fact that you got to ELM 11 means LeafSpy is able to communicate with the OBDII adapter.

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Fri Dec 22, 2017 1:11 pm

TimJolly wrote:Well, I have been using Leaf Spy for the last six months -- Carista to iPhone 6s. I downloaded Leaf Spy 1.6.28 last night, and today the iPhone cannot make a connection, no matter how hard it tries!

I tested with my Carista before I released and had no problems. Please take an ELM trace. See bottom of the help for how to do it.

------------------------
Just tested again using my Leaf simulator (daughter has the Leaf right now) and the Carista connects fine. Need to see the ELM trace to see what is going on.

alden
Posts: 6
Joined: Wed Jan 18, 2017 10:31 am
Delivery Date: 29 Oct 2014
Leaf Number: 308513
Location: Houston, TX

Re: iOS LeafSpy Pro Support

Fri Dec 22, 2017 4:25 pm

Turbo3 wrote:
Tewharaunz wrote:Hi Turbo3,

Thanks for the response.

I downloaded LightBlue Explorer and it definitely shows up as Viecar iOS ...screenshot attached.

https://photos.app.goo.gl/iCEpo495vXNsIUg13

I tapped the > then advertisement data for these details:

https://photos.app.goo.gl/lJMm8JqiXyA5QNvg2

I'm happy to do some further testing or beta testing possible solutions...

Cheers, David

Great, I will just change to looking for a broadcast ID with "Viecar" in it instead of an exact match.

I will include this with the 2018 Leaf compatibility update (not full support yet as some things have changed and need to located on the new Leaf).


I also bought a Viecar Bluetooth Adapter. I didn’t see it explicitly listed in yesterday’s update change log; it’s not working for me. I can see the adapter in Lightblue Explorer as “Viecar”. Here’s a screenshot https://photos.app.goo.gl/Ziy7fmhlcSjll0Jj2

Thanks!
Alden

chivalryx
Posts: 41
Joined: Mon Jul 04, 2016 3:38 pm
Delivery Date: 04 Jul 2016
Location: Coquitlam, BC

Re: iOS LeafSpy Pro Support

Sat Dec 23, 2017 7:57 pm

Turbo3 wrote:
chivalryx wrote:
dprendergast wrote:For the past week, I have gotten the exact same Ahrs level each day: 56.77. This seems weird, since up until a week ago, the level would fluctuate every day within a 54 to 58 range.

I thought maybe I could reset LeafSpy somehow, but I don't see a way to do that. I tried unplugging and re-inserting my OBDI adapter, but that didn't change it either.

Is this just coincidence, or might something else be going on?

David


I'm having the same issue. My battery health isn't updating, and hasn't since Nov 28th. Everything else seems fine.

Version 1.5.27

Chiv.

Send me an ELM trace so I can see what is going on. See bottom of Help file for how to do it.


I think I figured it out. The BMS doesn't report much if it's cold (It stopped around 5 degrees Celsius). Hopefully it comes back when the weather warms up again.

Chiv.
2013 White Pearl SV (No quick charge)
Weathertech custom floormats
Aftermarket LED Headlight upgrade (45W 4800 lumen/bulb)
12V 20Ah Prismatic LiFeMnPO4 Lead Acid replacement
Aftermarket Rear Backup Camera wired to NAV

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Thu Dec 28, 2017 11:11 am

chivalryx wrote:
Turbo3 wrote:
chivalryx wrote:
I'm having the same issue. My battery health isn't updating, and hasn't since Nov 28th. Everything else seems fine.

Version 1.5.27

Chiv.

Send me an ELM trace so I can see what is going on. See bottom of Help file for how to do it.


I think I figured it out. The BMS doesn't report much if it's cold (It stopped around 5 degrees Celsius). Hopefully it comes back when the weather warms up again.

Chiv.

When you say "doesn't report much" do you really mean the value does not change much under these conditions?

nickjensen
Posts: 9
Joined: Sun Nov 13, 2016 11:17 am
Delivery Date: 17 Oct 2016
Leaf Number: 416318
Location: Longmont, CO
Contact: Website

Re: iOS LeafSpy Pro Support

Thu Dec 28, 2017 1:34 pm

My amphr and battery health data has also been frozen since I took the latest update. I’ve never seen this before, even in much colder conditions. Are you sure the update didn’t break this somehow.

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Thu Dec 28, 2017 5:47 pm

nickjensen wrote:My amphr and battery health data has also been frozen since I took the latest update. I’ve never seen this before, even in much colder conditions. Are you sure the update didn’t break this somehow.

All these values are set to zero at the moment a connection the the Leaf is started. You should see all the values go to zero and then get refreshed with new values from the Leaf a short time later. That is how you can be sure you are getting fresh values from the Leaf.

nickjensen
Posts: 9
Joined: Sun Nov 13, 2016 11:17 am
Delivery Date: 17 Oct 2016
Leaf Number: 416318
Location: Longmont, CO
Contact: Website

Re: iOS LeafSpy Pro Support

Sun Dec 31, 2017 8:06 pm

Turbo3 wrote:
nickjensen wrote:My amphr and battery health data has also been frozen since I took the latest update. I’ve never seen this before, even in much colder conditions. Are you sure the update didn’t break this somehow.

All these values are set to zero at the moment a connection the the Leaf is started. You should see all the values go to zero and then get refreshed with new values from the Leaf a short time later. That is how you can be sure you are getting fresh values from the Leaf.



Well, it's not happening. All the trip data since the update has the exact same values for each trip. The data on the first screen isn't updating either. Everything else in the app runs as it should, but these 3 values aren't updating.

Return to “LEAF CANBus”