Madrilleno
Posts: 4
Joined: Sun Apr 08, 2018 12:30 am
Delivery Date: 24 Mar 2018

Re: iOS LeafSpy Pro Support

Tue Apr 10, 2018 4:11 am

Turbo3 wrote:
Madrilleno wrote:I have my LeafSpy connected successfully, I can read from the device. However, instead of showing a graph of cell pair balances, I just get an empty graph. Could you suggest what I might be doing wrong?

https://www.dropbox.com/sh/16bb3p0enot6ug5/AACgL5XDpNimoN4Mzhbe8DFIa?dl=0

Are you seeing the 96 Cell pair voltages on screen 1?

Can you take an ELM trace (see bottom of help file for how to do it) and send it to me?


Screen 1 is shown in one of the images uploaded to Dropbox and referenced by the link in my original post. I do not see the cell pair voltages.

I will grab an ELM trace later when I get home.

Mike

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Thu Apr 12, 2018 7:40 am

For those setting up a WiFi OBDII adapter for the first time, it appears Apple in one of the iOS 11 updates has changed the name used when manually setting up a network from "Static" to "Manual".

I will be updating the WiFi setup documentation to say "Static" or "Manual" .

Madrilleno
Posts: 4
Joined: Sun Apr 08, 2018 12:30 am
Delivery Date: 24 Mar 2018

Re: iOS LeafSpy Pro Support

Sat Apr 14, 2018 2:59 am

Turbo3 wrote:
Madrilleno wrote:I have my LeafSpy connected successfully, I can read from the device. However, instead of showing a graph of cell pair balances, I just get an empty graph. Could you suggest what I might be doing wrong?

https://www.dropbox.com/sh/16bb3p0enot6ug5/AACgL5XDpNimoN4Mzhbe8DFIa?dl=0

Are you seeing the 96 Cell pair voltages on screen 1?

Can you take an ELM trace (see bottom of help file for how to do it) and send it to me?


ELM trace sent to wattsleft.meter@gmail.com

Madrilleno
Posts: 4
Joined: Sun Apr 08, 2018 12:30 am
Delivery Date: 24 Mar 2018

Re: iOS LeafSpy Pro Support

Wed Apr 18, 2018 11:21 pm

Madrilleno wrote:
Turbo3 wrote:
Madrilleno wrote:I have my LeafSpy connected successfully, I can read from the device. However, instead of showing a graph of cell pair balances, I just get an empty graph. Could you suggest what I might be doing wrong?

https://www.dropbox.com/sh/16bb3p0enot6ug5/AACgL5XDpNimoN4Mzhbe8DFIa?dl=0

Are you seeing the 96 Cell pair voltages on screen 1?

Can you take an ELM trace (see bottom of help file for how to do it) and send it to me?


ELM trace sent to wattsleft.meter@gmail.com


Thanks to Jim, I now have the problem solved. Once again, it was a problem with the OBD reader - not fast enough to receive all of th3 data from my Leaf. New unit is a LeLink LE Bluetooth unit.

LELink^2 Configurable Auto On/Off Bluetooth Low Energy BLE OBD-II OBD2 Car Diagnostic Tool For iPhone/iPod/iPad and Android https://www.amazon.co.uk/dp/B0755N61PW/ ... 2AbMTE9END

lectricdav
Posts: 2
Joined: Wed Apr 18, 2018 5:47 pm
Delivery Date: 19 Apr 2018
Leaf Number: 315235

Re: iOS LeafSpy Pro Support

Sat Apr 21, 2018 7:44 pm

Hi,

So sorry if this has been covered but I could not find my answer in any of the posts. I have an iphone 6s with ios 11.3 and I just downloaded LeafSpy Pro v. 1.7.37. I have the adapter plugged into the leaf and it comes up in the Wif settings on my phone, but when I tried to follow your steps for ios wifi device setup it is not working. You already know there is no "static", only "manual" or "boot". I did try the manual but it did not allow me to leave the router field blank (would not give the option to save settings) and the DNS setting also seemed to be a problem. Am I missing something? I would love to try this out so please tell me what I am missing!

Thanks!

Turbo3
Gold Member
Posts: 1974
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: iOS LeafSpy Pro Support

Sun Apr 22, 2018 4:48 pm

lectricdav wrote:Hi,

So sorry if this has been covered but I could not find my answer in any of the posts. I have an iphone 6s with ios 11.3 and I just downloaded LeafSpy Pro v. 1.7.37. I have the adapter plugged into the leaf and it comes up in the Wif settings on my phone, but when I tried to follow your steps for ios wifi device setup it is not working. You already know there is no "static", only "manual" or "boot". I did try the manual but it did not allow me to leave the router field blank (would not give the option to save settings) and the DNS setting also seemed to be a problem. Am I missing something? I would love to try this out so please tell me what I am missing!

Thanks!

Manual is the same as Static. I have no idea why Apple decided to change the name. After that, the steps are the same.

1. Go to Settings/Wi-Fi and you should see your WiFi device listed under "CHOOSE A NETWORK". Tap the BLUE circled "i" to the right of your network name.

2. On the next screen under "IPV4 ADDRESS" tap "Automatic" so you can change it to "Manual".

3. After tapping "Automatic" you will get a screen with options of "Automatic" (default), "Manual" (what we want) and "BootP". Select "Manual".

4. After selecting "Manual" you will be able to enter the "IP Address" and "Subnet Mask" per the instructions in LeafSpy.

5. Enter 192.168.0.123 for the IP Address.

6. Enter 255.255.255.0 for the Subnet Mask. Note you must enter this in or the "Save" option will not be enabled. Leave the "Router" field blank.

If the Save option is not enabled then you have either not entered in the correct IP Address AND Subnet Mask or they are already saved. Go back and check that they exactly match the above values.

Note that the "Save" option will not be enabled if you have already saved the values. This might make you think you can not save without entering a Router value. You can test this by changing the "0" of the Subnet Mask to "4". Note that "Save" is now enabled since it does not match what is currently saved. Change it back to "0" and "Save" is disabled, not because you need to enter a Router value but because it has already been saved without a Router value.

-------------------------

After all this I must say I do not recommend a WiFi OBDII adapter. There is a new set of cost reduced (for the manufacturer) ones coming to market that do not support the Leaf. If you get stuck cycling up to state 14 with your Leaf turned On then you probably have one.

The recommended adapter is the LELink which is Bluetooth 4.x LE and requires no setup other than Bluetooth being turned on on your iPhone which it normally is.

lectricdav
Posts: 2
Joined: Wed Apr 18, 2018 5:47 pm
Delivery Date: 19 Apr 2018
Leaf Number: 315235

Re: iOS LeafSpy Pro Support

Tue Apr 24, 2018 11:27 am

Thank you Turbo3- my device is now working. Before I read your reply I managed to set the IP Address and the Subnet Mask to the correct value, and I also put in a value for the Router. ios allowed me to save these values and I was able to pair up LeafSpy with the OBD2 scanner. After reading your reply I went back and just tried deleting the router value, and leaving it blank. It worked! now everything is working!

The scanner I am using is a Veepeak Mini WiFi OBD2 Scanner Adapter
https://www.amazon.com/gp/product/B00WP ... UTF8&psc=1

It seems to work pretty well and even though it does not have a low-power mode I have left it plugged in for a few days and have not noticed and battery drain. I don't think I will need to leave it plugged in in the future, though.

Thanks,
DD

mischl
Posts: 6
Joined: Thu Oct 19, 2017 2:42 am
Delivery Date: 19 Sep 2017
Leaf Number: 012781

Re: iOS LeafSpy Pro Support

Wed Apr 25, 2018 10:32 pm

Hello

Which BT Adapter (from Amazon) works with an iPhone 5s and iOS 11.3?
KONNWEI KW902 cannot be linked, but works with Android....

Thanks in advance

cwerdna
Posts: 8093
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: iOS LeafSpy Pro Support

Wed Apr 25, 2018 10:41 pm

mischl wrote:Hello

Which BT Adapter (from Amazon) works with an iPhone 5s and iOS 11.3?
KONNWEI KW902 cannot be linked, but works with Android....

Turbo3 is the developer of LeafSpy. You'll notice he has recommended LELink numerous times for iOS.

Of course the KW902 won't work w/the iOS version. He's stated regular Bluetooth adapters won't work. They need to be in the list of Bluetooth LE adapters like at viewtopic.php?f=44&t=19147&p=460646&hilit=vgate#p460646 and viewtopic.php?p=470030#p470030.

You also shouldn't have bought a KW-902, even for Android: https://www.mynissanleaf.com/viewtopic.php?t=23776.

'13 Leaf SV w/premium package (owned)
'13 Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

Please don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

mischl
Posts: 6
Joined: Thu Oct 19, 2017 2:42 am
Delivery Date: 19 Sep 2017
Leaf Number: 012781

Re: iOS LeafSpy Pro Support

Wed Apr 25, 2018 10:53 pm

Thanks a lot for the fast and informative reply.

It is very hard to find and pick the right information out of threads.

Would this one be ok?
Otherwise this I guess.

Thanks a lot again, very appreciated

Return to “LEAF CANBus”