CRBAman
Posts: 6
Joined: Sat Nov 28, 2015 3:33 pm
Delivery Date: 28 Nov 2015

start A/C with CAN BUS

Wed Dec 07, 2016 2:16 am

Hello!

Maybe somebody knows what code need to sent to EV/CAN bus to start heater or cooler like it does with Nissan Connect?

I want to start A/C when car is switched off.
Nissan leaf SV 2013, Ukraine
SimpleEvse 6.6kWh

mentaluproar
Posts: 15
Joined: Tue Jan 05, 2016 11:22 am
Delivery Date: 09 Jan 2015

Re: start A/C with CAN BUS

Fri Dec 09, 2016 4:12 pm

This is exactly what I'm looking to do. There must be some way to trigger the remote start via OBD.

carrott
Posts: 6
Joined: Tue Jan 03, 2017 2:53 pm
Delivery Date: 03 Feb 2015

Re: start A/C with CAN BUS

Tue Jan 03, 2017 3:12 pm

You can wake the car up and start the climate control by sending a frame or two on the EV CAN bus, see https://github.com/openvehicles/Open-Vehicle-Monitoring-System/blob/470af78c4b9315da0062d2fa2bc5d3fdd7561822/vehicle/OVMS.X/vehicle_nissanleaf.c#L405 which implements remote climate control in the OVMS project.

Gen 1 cars require a wire to be toggled to 12v to wake up the system before you can send the climate control command. I unplugged the TCU on my Gen 1 Leaf and connected the OVMS to it's plug to access the EV system activation request signal. See https://carrott.org/blog/archives/158-OVMS-Nissan-Leaf-Remote-Climate-Control.html

I've had a report that a Gen 1 car doesn't need the EV system activation request signal, so maybe there are some Gen 1 firmware versions that implement the pure CAN bus wakeup that is present in the Gen 2. I haven't tested many Gen 2 cars, but I have found that not all Gen 2 cars work -- I suspect cars with a TCU installed don't work because the OVMS sends "turn on" and the Nissan TCU sends "idle" but I haven't had a chance to test this.

carrott
Posts: 6
Joined: Tue Jan 03, 2017 2:53 pm
Delivery Date: 03 Feb 2015

Re: start A/C with CAN BUS

Thu Jan 19, 2017 1:20 am

I spent some time with a friend's Gen 2 Nissan Leaf and got to the bottom of why the remote climate control works on some cars and not others.

It turns out that if you have CARWINGS (now called NissanConnect) hardware in your car, the Nissan TCU module sends "Status" (0x4e) and "Idle" (0x86) messages on CAN frame 0x56e. These override the "CC On" (0x4e) message (0x4e) I'm sending with the OVMS and shut the car down.

If you have a TCU module, the solution is to unplug it. I haven't noticed any problems doing this, I unplugged my TCU (on my Gen 1 I had to do this to access the hardware wakeup wiring) about 6 months ago. My friend has been going a few days in his Gen 2 with no problems.

Unplugging isn't terribly difficult on a right hand drive car, you have to remove a panel above the driver's feet and then contort yourself in to press the release latch and pull out the big plug. I didn't bother unplugging the antenna and USB connection to the AV unit, and I coudln't work out how to release the entire module without taking more of the car apart.

I do notice a check engine light when I use the remote climate control but it goes away after your turn the car off an on again and doesn't affect the performance of the car. I'm guessing something notices that the OVMS isn't faithfully emulating all the TCU functions. If anyone has a working NissanConnect and could capture the can bus for an entire remote climate control session, from startup to shutdown, maybe I can get rid of this problem.

mentaluproar
Posts: 15
Joined: Tue Jan 05, 2016 11:22 am
Delivery Date: 09 Jan 2015

Re: start A/C with CAN BUS

Thu Jan 19, 2017 8:09 am

Can I see a diagram or photo of what I'm supposed to disconnect?

carrott
Posts: 6
Joined: Tue Jan 03, 2017 2:53 pm
Delivery Date: 03 Feb 2015

Re: start A/C with CAN BUS

Sun Jun 04, 2017 2:45 pm


Mitchell
Posts: 27
Joined: Tue Jun 02, 2015 1:46 pm
Delivery Date: 05 Jan 2016
Leaf Number: 301722
Location: Toronto, Canada

Re: start A/C with CAN BUS

Mon Jun 05, 2017 5:37 pm

I posted some detail on starting the Climate Control in my post here (in point 2, after the text "Now for the three 'buttons'").

So while the Carloop is asking for the Climate Control to start, the TCU is sending a message (every 100 ms) to the Climate Control to not change, and the Leaf's VCM would not be expecting to receive such conflicting messages. After much testing I found that it usually works to send the 0x56E messages more often than the TCU, and send them for longer than the TCU would when it starts the Climate control. I settled on sending the bus wake-up (0x68C 00) , followed 50 ms later by 0x56E 4E 08 12 00 to turn on Climate Control, then delaying another 20 ms and repeating this Climate Control command another 45 times at 60 ms intervals.
2016 Leaf SL, grey, received 20160105, OpenEVSE

Return to “LEAF CANBus”