Page 1 of 1

Leafspy & relay chatter under the hood?

Posted: Wed Jul 12, 2017 11:40 am
by sandeen
I have a 2012 SL, and LeafSpy pro. i'd noticed before that when the car was sitting and charging, I heard relay chatter under the hood, on the opposite side of the 12v battery. I chalked this up to battery management fiddling with cells, or something.

But today I realized that this only happens when LeafSpy is polling the car. If I exit LeafSpy, the chatter stops.
I'm a bit concerned that the LeafSpy polling could be shortening the life of some components in the car, specifically the relays which I assume to be making this noise. Has anyone else noticed this? Turbo3, any idea which parts of the polling may be causing this?

Thanks,
-Eric

Re: Leafspy & relay chatter under the hood?

Posted: Wed Jul 12, 2017 12:01 pm
by Reddy
Yes, I've noticed this with my 2011 SL. I just unplug both the LeafSpy and charging. I'm not sure if they are related, but I agree: When there's extra noise I'd be worried.

Re: Leafspy & relay chatter under the hood?

Posted: Wed Jul 12, 2017 12:42 pm
by sandeen
It'd be nice to be able to set the polling interval, there's really no need to cycle this as quickly as possible, I think.

For now I guess I'll stop leaving LeafSpy running in the garage while I charge .... :)

Re: Leafspy & relay chatter under the hood?

Posted: Thu Jul 13, 2017 2:02 am
by lkkms2
Don't leave the OBDII Bluetooth connected. Pull out when not using.

Having an extension cable is a good idea. Leave the extension plugged in, but disconnect the OBDII.

I had this problem with my 2011 Leaf.

Re: Leafspy & relay chatter under the hood?

Posted: Thu Jul 13, 2017 6:57 am
by Marktm
sandeen wrote:I have a 2012 SL, and LeafSpy pro. i'd noticed before that when the car was sitting and charging, I heard relay chatter under the hood, on the opposite side of the 12v battery. I chalked this up to battery management fiddling with cells, or something.

But today I realized that this only happens when LeafSpy is polling the car. If I exit LeafSpy, the chatter stops.
I'm a bit concerned that the LeafSpy polling could be shortening the life of some components in the car, specifically the relays which I assume to be making this noise. Has anyone else noticed this? Turbo3, any idea which parts of the polling may be causing this?

Thanks,
-Eric


I tried to replicate your issue with my 2012 Leaf. What I hear is a very slight "crackling" noise that appears to be coming from the junction box. It happens while charging whether or not I have the OBDII dongle in place - and of course having LeafSpy on/off makes no difference (always makes the noise when charging). I have the LELINK (low energy bluetooth/iOS) dongle. What operating system is your LeafSpy app?

I leave my dongle in place always and have not had any 12v battery drain issues when gone over a week - with the original battery.

Re: Leafspy & relay chatter under the hood?

Posted: Thu Jul 13, 2017 7:58 am
by sandeen
I guess I can do a bit more investigation to be sure, but before I started this thread I started/stopped/started/stopped leafspy, and the noise came and went with it.
On the other hand, I went back out this morning and turned on leafspy and heard nothing... ?

yeah, the sound is sort of a tick-tick-tick type sound, not rhythmic but semi random.

I'm running leafspy on android with a bluetooth adapter.

Re: Leafspy & relay chatter under the hood?

Posted: Thu Jul 13, 2017 8:14 am
by sandeen
lkkms2 wrote:Don't leave the OBDII Bluetooth connected. Pull out when not using.

Having an extension cable is a good idea. Leave the extension plugged in, but disconnect the OBDII.


Sure, that's a very big-hammer approach. :) But I was intentionally gathering data while charging, and became concerned that it might be hard on the car.

Re: Leafspy & relay chatter under the hood?

Posted: Mon Jul 17, 2017 1:26 pm
by GerryAZ
Make sure you are running a late version of LEAF Spy Pro. The earlier software versions did cause one of the relays to cycle, but I thought later software versions fixed this. I have no way to test with 2011 or 2012 now. There is no relay chatter with my 2015.

Re: Leafspy & relay chatter under the hood?

Posted: Mon Jul 17, 2017 1:33 pm
by sandeen
I get it at some times and not others - haven't narrowed it down. In fact one time when I opened the door to pop the hood and listen more closely, that stopped the chatter. (!)

I'm on 0.39.97 - latest, I think.

I guess the relays are probably replaceable, so maybe it's not a huge deal. Just seems odd.

Re: Leafspy & relay chatter under the hood?

Posted: Sun Jul 30, 2017 11:43 am
by AntronX
It's been explained in the past somewhere on here. The relay chatters to make sure the host computer has power during critical data read in case of loss of supply power. It is caused by Leaf's software, not Leafspy. My 2011 SL does it. I found that disabling Bluetooth on my phone instantly stops all chatter for good. No need to unplug the dongle. I now got into a habit of turning it off when I don't need to check the SOC during charging. The relay likely has millions of cycles before failure, so it should last.