hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 2:29 pm

So I went for a test drive on a loaded 2013 Leaf SV today. 24k 11/12 bars showing. Manu date of 04/2013 on the door plate. Drove over an hour to see the car only to have problems with LeafSpy.

Disclaimer: As of a week ago I had never head about LS, but thanks to this forum and it's outstanding members I am now more knowledgeable than most dealer salesman on the leaf. The OBD2 Interface I have is an ELM327 v1.5 (see pic below). My phone is a Samsung Galaxy note 5 running Android 6.1

I plugged in the OBD interface, launched the app and went to the "Select OBDII" menu. I selected my device and was prompted for the pairing code. Now I've used this device in the past with no issues (as a matter of fact I tested it on the way home from the dealership on my Acura and it connected and worked just fine with an app called TorquePro). After finally getting the code right. The box on the lower right hand corner of the screen went Green with "Connected" displayed. But, there was no data. All the figures were 0.

The car was on and in park. I really don't know if I was supposed to do anything else to get the numbers other than go into the settings screen and select the year of my vehicle. It just seemed odd that I appeared to be connected, but got no data. I immediately downloaded the paid version since I intended to buy it anyway, but no change. I messed with it for about 15 minutes and finally gave up. Since the car had 11/12 bars and a manufacturer date of 4/13, I did not hesitate to walk away from the lot since I didn't have any LeafSpy data,

I want to be prepared next time, so I could use some help on how to use this app if I'm not using it right. I'll probably go to the nearest dealer that has a leaf for sale and test it out before committing to another long drive. :(

Image
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 5:41 pm

So after reading some posts about the problematic OBD connectors, I've ordered two that are supposed to be supported:

BAFX Products 34t5 Bluetooth OBDII Scan Tool for Android Devices
https://www.amazon.com/gp/product/B005NLQAHS/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

KONNWEI KW902 Mini ELM327 Bluetooth Wireless OBD-II OBD2 Car Auto Diagnostic Scan Tools compatible with Android & Windows PC (Orange)
https://www.amazon.com/gp/product/B01M19GKRP/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
(hopefully wont need to do resistor surgery)

I'll report back on my results.
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

alozzy
Posts: 667
Joined: Fri Jan 20, 2017 4:25 pm
Delivery Date: 18 Jan 2017
Location: Vancouver, BC
Contact: Website

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 5:51 pm

Was the Leaf in running mode (ie with foot on brake while pressing the power button)? If it was in AUX/RADIO and then you pressed the power button a second time, then Leaf Spy won't be able to read all the metrics in that mode.
Vancouver, CA owner of a 2013 Ocean Blue SV + QC, purchased 01/2017 in WA
Zencar 12/20/24/30A L1/L2 portable EVSE
1-1/4" Curt #11396 hitch
After market, DIY LED DRLs
LeafSpy Pro + Konnwei KW902 ELM327 BT OBDII dongle
Loving my first BEV :D

hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 6:00 pm

alozzy wrote:Was the Leaf in running mode (ie with foot on brake while pressing the power button)? If it was in AUX/RADIO and then you pressed the power button a second time, then Leaf Spy won't be able to read all the metrics in that mode.


Yeah. The salesman had me put it in running mode. All I had to do was shift into D to get moving, so I'm assuming it was in running mode.

How can you differentiate the two? The dash was all lit up and it was chiming endlessly (door open)
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

alozzy
Posts: 667
Joined: Fri Jan 20, 2017 4:25 pm
Delivery Date: 18 Jan 2017
Location: Vancouver, BC
Contact: Website

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 6:12 pm

Sounds like it was in run mode. Just look for the little green car with the two headed arrow below it:

Image
Vancouver, CA owner of a 2013 Ocean Blue SV + QC, purchased 01/2017 in WA
Zencar 12/20/24/30A L1/L2 portable EVSE
1-1/4" Curt #11396 hitch
After market, DIY LED DRLs
LeafSpy Pro + Konnwei KW902 ELM327 BT OBDII dongle
Loving my first BEV :D

hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 6:18 pm

alozzy wrote:Sounds like it was in run mode. Just look for the little green car with the two headed arrow below it:



Yeah, it was in running mode. Just as well. It was in great shape and had all the bells and whistles, but I know I can find a 12bar model. There are no shortages. Might just settle for an S model with QC installed.

One of my two new OBD interfaces will be in tomorrow and hopefully I can test it out. It's just awkward sitting there fiddling with my phone, trying to connect to the car while the salesman is probably thinking "What the hell is this guy doing??"
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

cwerdna
Gold Member
Posts: 7188
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 7:17 pm

hackdroot wrote:KONNWEI KW902 Mini ELM327 Bluetooth Wireless OBD-II OBD2 Car Auto Diagnostic Scan Tools compatible with Android & Windows PC (Orange)
https://www.amazon.com/gp/product/B01M19GKRP/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
(hopefully wont need to do resistor surgery)

I would NOT use the KW902 w/o measuring its resistances on the pins pointed out by viewtopic.php?f=44&t=23776 first. In fact, I wouldn't have ordered that one at all.

'13 blue Leaf SV w/premium package (owned)
'13 blue Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 7:36 pm

cwerdna wrote:
hackdroot wrote:KONNWEI KW902 Mini ELM327 Bluetooth Wireless OBD-II OBD2 Car Auto Diagnostic Scan Tools compatible with Android & Windows PC (Orange)
https://www.amazon.com/gp/product/B01M19GKRP/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
(hopefully wont need to do resistor surgery)

I would NOT use the KW902 w/o measuring its resistances on the pins pointed out by viewtopic.php?f=44&t=23776 first. In fact, I wouldn't have ordered that one at all.


Yeah. I read that thread after ordering. I'm an electrical guy, so I have no problem removing that surface mount resistor.

The BAFX will come in first, so hopefully that KONNWEI will go back to amazon unopened.
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

Deathwater
Posts: 14
Joined: Thu Feb 02, 2017 4:01 pm
Delivery Date: 01 Feb 2017
Leaf Number: 30332
Location: Hilo, Hawaii

Re: Went for test drive, couldn't get LeafSpy to work.

Mon Apr 17, 2017 9:55 pm

----------------------------
2017 Silver Nissan Leaf SL
Ex-2010 Mazdaspeed 3 owner
Growing up is tough

hackdroot
Posts: 67
Joined: Sat Apr 15, 2017 12:54 pm
Delivery Date: 15 Apr 2017
Location: East Bay Area, CA

Re: Went for test drive, couldn't get LeafSpy to work.

Fri Apr 21, 2017 11:38 pm

The following worked fine on my phone (it just updated to Android 7 as well)

BAFX Products 34t5 Bluetooth OBDII Scan Tool for Android Devices
https://www.amazon.com/gp/product/B005N ... UTF8&psc=1

The KONNWEI KW902 will be going back to amazon.
2013 Leaf SL (12/2013) + Premium package 31,000 miles - 58.8AHr - 89%SOH

Return to “New Members & Newbie Questions”