metzroth
Posts: 7
Joined: Wed Sep 14, 2011 8:44 am
Delivery Date: 03 Sep 2011
Leaf Number: 007354

TCU Issue, please help.

Thu Jul 19, 2018 5:56 am

I am having a TCU issue that is causing the leaf to throw the yellow EV light on. Here's the DTC codes...

P312A 00C0 EV/HEV Comm Error EVC-208
P3131 00C0 EV/HEV System Shutoff Timeout
P31C2 00C0 EV/HEV TCU EVC-273
With a current code of....
U1000 000B TCU CAN Comm Circuit

My understanding of all this is that either the TCU has lost it's "activation" or is stuck on. Please confirm that understanding as well as offer any suggestions... like go to this area of the car and unplug the ^&*% TCU module :-). My leaf has 106,000 miles on it and I don't want to go pay Nissan $149 just to unplug the TCU, re-activate it, or tell me I can pay them $350+$149 to fix it.

User avatar
Stanton
Posts: 2107
Joined: Thu Feb 03, 2011 10:56 am
Delivery Date: 01 Sep 2011
Leaf Number: 7458
Location: Plano, TX
Contact: Website Twitter

Re: TCU Issue, please help.

Thu Jul 19, 2018 8:27 am

2 questions:
1) did you upgrade to the 3G TCU?
2) have you read the (very long) upgrade thread...which contains just about everything you want to know about the TCU?
2011 Blue Ocean SV w/floor mats & window tint
12v LiFePO4 battery & FIAMM 74100 horns
Wet Okole seat covers (front)
Tor's low-power heater mod
2013 sun visor
3G modem upgrade
L2 EVSE Upgrade
Battery Pack replaced (Rev E) @51 months and 41k miles

metzroth
Posts: 7
Joined: Wed Sep 14, 2011 8:44 am
Delivery Date: 03 Sep 2011
Leaf Number: 007354

Re: TCU Issue, please help.

Thu Jul 19, 2018 9:29 am

2G upgraded to 3G in April 2016. Reading the threads, the first thing I’m going to try is unplugging the grey wire harness from it and see if the yellow warning light will disappear. While I’m under the glove box, I’ll change the cabin air filter as well since I’m already there :-)
Last edited by metzroth on Thu Jul 19, 2018 10:27 am, edited 1 time in total.

cwerdna
Posts: 8291
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: TCU Issue, please help.

Thu Jul 19, 2018 9:34 am

Just pull the fuse for the stereo/audio system under the hood to get the TCU unstuck. To mitigate the issue that seems to cause the P3131 DTC and the yellow ! car, see below.

viewtopic.php?p=515624#p515624
viewtopic.php?p=516453#p516453

Supposedly NTB18-045 addresses these probs. See viewtopic.php?p=531975#p531975. Unfortunately, I haven't seen the PDF of the TSB myself nor do I know if it's really effective yet. Will probably get it done in the near future.

'13 Leaf SV w/premium package (owned)
'13 Leaf SV w/QC + LED & premium packages (lease over, car returned)
'06 Prius

Please don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

Lothsahn
Posts: 72
Joined: Thu Apr 05, 2018 4:35 pm
Delivery Date: 04 Jan 2018
Leaf Number: 007797

Re: TCU Issue, please help.

Sun Aug 05, 2018 9:50 pm

Or follow the instructions here to disconnect the TCU entirely:

viewtopic.php?f=27&t=25949&p=528909#p528909

Note: this is for the 2G model but the 3g should be about the same.
2011 Silver SV, purchased 2018, lives in Missouri (previously in CA)
LeafSpy Pro + BAFX Products OBDII dongle
7 bars and really feeling the range squeeze

Supersleeper
Posts: 116
Joined: Mon Aug 07, 2017 10:04 am
Delivery Date: 06 Aug 2017
Location: SF Bay Area

Re: TCU Issue, please help.

Thu Aug 09, 2018 12:14 pm

IDK why, but I've been having more issues lately. About once a week now, where before it was only about once a month. I really wish there were an easy and permanent fix to this. I'm about to go and find the actual +12v supply to the TCU harness and install a toggle switch. Sometimes pulling the fuse doesn't solve it, and I'm tired of pulling the battery terminal, resetting the clock, and everything else.

Another thought was to just go and find a extremely low-power timer circuit that will automatically kill the power to the TCU once every few days for about 2 min.

LeftieBiker
Posts: 9611
Joined: Wed May 22, 2013 3:17 am
Delivery Date: 31 May 2013
Location: Upstate New York, US

Re: TCU Issue, please help.

Thu Aug 09, 2018 12:41 pm

I'm about to go and find the actual +12v supply to the TCU harness and install a toggle switch.


That was my suggestion, last year. I'd just turn the damned thing on when needed, leaving it off otherwise.
Scarlet Ember 2018 Leaf SL W/ Pro Pilot
2009 Vectrix VX-1 W/18 Leaf modules, & 3 EZIP E-bicycles.
PLEASE don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

Supersleeper
Posts: 116
Joined: Mon Aug 07, 2017 10:04 am
Delivery Date: 06 Aug 2017
Location: SF Bay Area

Re: TCU Issue, please help.

Thu Aug 09, 2018 12:52 pm

LeftieBiker wrote:
I'm about to go and find the actual +12v supply to the TCU harness and install a toggle switch.


That was my suggestion, last year. I'd just turn the damned thing on when needed, leaving it off otherwise.


I’d always forget. But I was also thinking, maybe something more clever. Maybe have a relay staged off of accessory, so that when you shut off the car, it would momentarily power-cycle the TCU. You could do this with a simple relay, and 12v Super capacitor. The capacitor would draw current off of the relay when accessory is lost, momentarily keeping the relay triggered to break the circuit. Then once he capacitor is charged, the relay would then close the circuit.

This way, you’d always have a fresh system when you leave the car.

baustin
Posts: 673
Joined: Tue Feb 24, 2015 1:23 pm
Delivery Date: 09 Mar 2015
Leaf Number: 402162
Location: North Las Vegas, NV

Re: TCU Issue, please help.

Fri Aug 10, 2018 3:48 am

Supersleeper wrote:IDK why, but I've been having more issues lately. About once a week now, where before it was only about once a month. I really wish there were an easy and permanent fix to this. I'm about to go and find the actual +12v supply to the TCU harness and install a toggle switch. Sometimes pulling the fuse doesn't solve it, and I'm tired of pulling the battery terminal, resetting the clock, and everything else.

Another thought was to just go and find a extremely low-power timer circuit that will automatically kill the power to the TCU once every few days for about 2 min.


What is the state of your12v battery? The 3g TCU is more sensitive to the voltage level than the 2g unit was. Since I replace the original 12v (over 4 years old) with a AGM style battery, the number of times the TCU had to be reset dropped considerably. Now, I only need to do a fuse pull (about 60 seconds) once every two to three months.
2013 Leaf SV - Cayenne Red - QC Port - LED Headlights

Supersleeper
Posts: 116
Joined: Mon Aug 07, 2017 10:04 am
Delivery Date: 06 Aug 2017
Location: SF Bay Area

Re: TCU Issue, please help.

Sat Aug 11, 2018 5:21 pm

It’s a brand new gel cell.

Return to “Problems / Troubleshooting”