Page 3 of 3

Re: Moderator Announcements

Posted: Wed Oct 16, 2019 8:59 am
by jjeff
I had the same thing happen with Chrome about 3hrs ago but unlike some other times I've gotten such a warning(on different sites using other browsers) I was unable to get to the site, even clicking on advanced. I also use FF but didn't try it this morning due to lack of time, I'm not sure if I've ever clicked advanced on Chrome so I can't say for sure how it acts. Chrome did say something about someone could be spoofing the site and again didn't seem to want to let me in, everything seems fine now :)

Re: Moderator Announcements

Posted: Wed Oct 16, 2019 5:46 pm
by coulomb
I used Opera mini on my phone, and installed Opera for Windows in my effort to be unsafe. Neither Firefox nor Chrome would let me click through (even with Advanced).

Re: Moderator Announcements

Posted: Wed Oct 16, 2019 6:35 pm
by LeftieBiker
Chrome let me through after warning me.

Re: Moderator Announcements

Posted: Wed Oct 16, 2019 9:11 pm
by Nubo
Safari told me it couldn't establish a secure connection; I didn't dig any deeper.

Re: Moderator Announcements

Posted: Wed Oct 16, 2019 10:15 pm
by alozzy
wxxyz wrote:
Wed Oct 16, 2019 7:29 am
I've fixed the problem! The certificate renewed, but it needed a manual tweak to work correctly.

Call for technical help: This will likely be a problem every 90 days when the Let's Encrypt auto renews. The site is running on a VPS and Let's Encrypt correctly renewed, but I needed to click a 'reload web servers' button in the control panel to get it to work. Any ideas how to fix that? PM or email me and I can give you more details.
The easy fix is to pay $20 for a 1 yr cert that has broad browser support. Here's just one example:

https://www.ssl2buy.com/alpha-ssl-certificates