Page 230 of 253

Re: The official "I got my Leaf" thread

Posted: Mon Feb 12, 2018 11:51 am
by manchi
I got a 2018 Gun-Metal Leaf SV with Technology and Weather package. Took delivery last Friday in metro Atlanta. Anyone who got a 2018 figured out what's up with the Android play on the car? I can't get it to enable.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 15, 2018 8:17 pm
by NJLeaf75
I took delivery of a brilliant silver SL here in northern NJ on February 10, 2018. I wanted a gun metallic SV with the technology package, but the only SVs they had in my area were SVs with the Weather Package. I figured I would go and test drive an SV and wait for the specific model I wanted to arrive later in the Spring. I wound up test driving an SL. I was impressed with the test drive. The dealer realized that I was adamant about the technology package, but asked if I would compromise on the color. When I said yes, he offered me brilliant Silver SL (Tech and Weather pkg) for $36,500. I thought about it for a bit and then signed on the dotted line.

It is my first time owning a Nissan. This Leaf will replace my 2007 Prius and will go alongside my 2017 Prius Prime.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 15, 2018 8:24 pm
by LeftieBiker
IIRC, the weather package is standard on the SL, but I may be wrong - especially regarding the 2018 Leafs.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 15, 2018 8:32 pm
by NJLeaf75
LeftieBiker wrote:IIRC, the weather package is standard on the SL, but I may be wrong - especially regarding the 2018 Leafs.
I think that is right. They also charge you less for the weather package on the SL...likely because you pay more for the trim. At the end of the day, I git a fully loaded 2018 Leaf for $36,500. A little more than I planned to spend, but I am happy with the purchase.

Re: The official "I got my Leaf" thread

Posted: Mon Feb 19, 2018 6:26 am
by jonathanfields4ever
Only had my Leaf for 9 days so far and it’s been nothing but trouble. I’m livid. First the USB port was messed up and CarPlay didn’t work. Then the nav system had the car in the wrong place when I was in downtown Osaka and put me on the wrong toll road. This added a full hour and $10 to my trip.

Took it in, got a loaner Leaf and it did the exact same thing. I’m on the highway nowhere near any thing and the computer is constantly yelling at me for speeding through school zones. WTF

I get my Leaf back and they tell me it’s a problem all 2018 models experience in cold weather. How friggin’ long did they know about this issue? But the USB works, so I’m happy... until I get home and realize the backup camera is blurry and the button on the center console that’s supposed to bring up the settings just beeps and does nothing.

There’s nothing wrong with the driving aspects, and I’m happy to report an average of 8.1km/kWh, but the electronics are absolute dog****.

The Model 3 fanboys were right. I should have waited until it came out.

Re: The official "I got my Leaf" thread

Posted: Mon Feb 19, 2018 7:35 am
by SageBrush
jonathanfields4ever wrote: The Model 3 fanboys were right. I should have waited until it came out.
As a card carrying Model 3 fanboy, I have to say that I'd be very surprised if Nissan does not fix the Nav pretty soon for you since it sounds like a wide-spread problem.

Be patient, it is a new model. I'd only care to shut off the alerts for now.

Re: The official "I got my Leaf" thread

Posted: Mon Feb 19, 2018 10:10 am
by tucsonjak
Hello!

I bought a 2012 SL this weekend from a private party.

I didn't realize today was a federal holiday so I've only driven it home from the sellers house as I don't have it registered and plated yet.

I'm quite excited to own my Leaf.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 22, 2018 6:41 am
by jonathanfields4ever
Just a little update. The dealership says they’ve got all the issues sorted out. I get my car back on Saturday. I drove like a maniac through the mountains in the loaner Leaf they gave me and still managed 6.3km/kWh. It’s really quite fun to use e-Pedal with the car in B mode.

Hopefully they really do have it fixed. It turns out they forgot to connect something when they gave me a new nav unit. And the issue with the car’s location being wrong in cold weather has apparently been resolved nation wide.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 22, 2018 9:13 pm
by TheLostPetrol
I got a 2015 SV w/QC yesterday 2018-02-21. It's pearl white with the light grey interior, which I'm very happy with because I'll be parking in a mostly unshaded parking lot next summer. The battery seems to be in almost suspiciously good health after waiting 7 months from manufacture to in-service, and 73 days (albeit Dec-Feb) on a dealer's lot just now. It still needs the 3G TCU upgrade.

The last Nissan we bought was a Stanza about 25 years ago.

Re: The official "I got my Leaf" thread

Posted: Thu Feb 22, 2018 10:22 pm
by LeftieBiker
Not all Leafs sit on the lot with a high SOC. Mine was a demo, I think, and was actually pretty low. It seems to be an unspoken but common dealer rule to keep EVs with barely 25 miles on the GOM.