Page 2 of 2

Re: Main computer and HV wiring change

Posted: Mon Mar 11, 2019 12:30 pm
by DarthBane
Nothing water related happened, in case you mean if I crashed in a ditch full of water or such other incident.
The way it started is the yellow light (EV System warning light) turning on on the dashboard instead of the green arrows. When the yellow light turned on, I could not put the car in drive nor reverse, but only in park or neutral. So I got it towed to the dealership. They had a fairly quick look I think, and thought it was a simple switch or relay that froze and caused the light to turn on. They erased the code, and let me go. The car was working after erasing the code.
The next day I was at the office, started the car, all was good, but while driving the EV warning light turned on again. So I went straight home (didn't want to turn it off because I didn't know if it would restart or not). Parked it at home, turned it off, and turned it back on, and the yellow light was still on, and again could not engage drive nor reverse. Because of what the dealership had done, I decided to delete the code myself with LeafSpy. Then the car was good for roughly a week, and the EV light turned on again.
At that point I didn't want to just delete the code because then we would never find the cause of this problem, so got it towed again. That is when the dealership took a while to find the problem of water infiltration. The water infiltrated through the HV wiring, and this is why they want to change the wiring as well. They think the water came from condensation more than from a splash from the road or something like that.
That is pretty much the whole story!

PS: as far as weather goes, we had a real shitty winter: +5ยบ C one day, the next day -20, so you can imagine what kind of ice rink we had on those days. But still, no water should go in there no matter what weather we have.