DaveinOlyWA
Posts: 14156
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Sun Sep 01, 2013 2:23 pm

Turbo3 wrote: There is already a non-visible button to go between screens.

It is at the bottom of the screen (black background area) starting from the page dot area and extending to the version number in the middle.

Tap that area to move ahead one screen or tap and hold to move back one screen.

Everyone knows about this area, right? It was asked for many weeks ago and has been there for a long time now.
oh thanks! good to know. I have only had mine for a day so am completely out of the loop as far as operation goes especially any new stuff. I guess i should RTFM :roll:

**edit**
oh one thing i was going to ask you. When i turn on the batt app and LEAF is off, there is a solenoid clicking sound coming from the black box on the right front side on top of the wheel well. what is it?
Last edited by DaveinOlyWA on Sun Sep 01, 2013 3:18 pm, edited 1 time in total.
2011 SL; 44,598 miles. 2013 S; 44,840 miles.2016 S30 deceased. 29,413 miles. 2018 S40; 15,000 miles, 478 GIDs, 37.0 kwh 109.81 Ahr , SOH 94.61, Hx 120.15
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

User avatar
vrwl
Forum Supporter
Posts: 846
Joined: Tue May 15, 2012 2:16 pm
Delivery Date: 26 Jun 2012
Leaf Number: 8597
Location: Northeastern PA/Poconos

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Sun Sep 01, 2013 2:41 pm

Turbo3 wrote: There is already a non-visible button to go between screens.

It is at the bottom of the screen (black background area) starting from the page dot area and extending to the version number in the middle.

Tap that area to move ahead one screen or tap and hold to move back one screen.

Everyone knows about this area, right? It was asked for many weeks ago and has been there for a long time now.
Sorry, no, didn't realize that. I must have been hitting that accidentally when I was tapping the "dots" in the lower left corner, but didn't realize the long press would reverse the process.
Vicki
2011 Silver SL-Mfg 8/11-Purch 6/12
34000 miles

User avatar
FalconFour
Gold Member
Posts: 324
Joined: Wed Sep 19, 2012 12:07 pm
Delivery Date: 14 Sep 2012
Leaf Number: 008681
Location: San Jose, CA
Contact: Website Facebook

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Sun Sep 01, 2013 6:30 pm

Remember, the forum thread is very much fleeting in nature... permanent in storage, but very hard to find the information buried tens of pages behind the current page. Without some intuitive visual cue, there's no way to tell what the heck the interface elements in the app are going to do! I've actually found myself tapping every element on the screen to see if it did something else, just to figure out what else can be done... which works for me, since I'm a geek who always does that. :lol: I knew I could switch pages in one direction that way, but grabbing the battery graphic and swiping is how I usually do it. ;)
100% gas-free since September 2012
2011 LEAF SL - Sep 2012~Sep 2014 - 35,737 miles
2013 LEAF S+Charge - Jan 2014-Feb 2017 - 68,065 miles
2014 LEAF SV+Premium+QC - Feb 2017-present

kevinleaf
Posts: 178
Joined: Mon Jun 03, 2013 4:19 pm
Delivery Date: 03 Jun 2013

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Mon Sep 02, 2013 10:49 am

oh one thing i was going to ask you. When i turn on the batt app and LEAF is off, there is a solenoid clicking sound coming from the black box on the right front side on top of the wheel well. what is it?
I have had that clicking sound as well. It doesn't happen all the time and I can't say whether it is when I use the battery app or when I leave the ELM327 plugged in. It doesn't happen all the time.

Door lock / unlock settings are great! Finally my car doesn't lock me in all the time.

non-visible buttons: think of the app from the perspective of someone seeing it for the first time and not reading all the forum posts here. Features like this should be more intuitive. It is definitely a challenge with limited screen real estate. There are so many features packed into this software its hard to find them all.

Perhaps a video walkthru / demo for new users with screen captures? Once I understand it more I can try to do this.

"terminate instead of run in background": personally to do continuous logging, even when I get a phone call or switch apps, is important. So I don't want the program to quit when i switch apps.

DaveinOlyWA
Posts: 14156
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Mon Sep 02, 2013 11:05 am

kevinleaf wrote:
oh one thing i was going to ask you. When i turn on the batt app and LEAF is off, there is a solenoid clicking sound coming from the black box on the right front side on top of the wheel well. what is it?
I have had that clicking sound as well. It doesn't happen all the time and I can't say whether it is when I use the battery app or when I leave the ELM327 plugged in. It doesn't happen all the time.

Door lock / unlock settings are great! Finally my car doesn't lock me in all the time.

non-visible buttons: think of the app from the perspective of someone seeing it for the first time and not reading all the forum posts here. Features like this should be more intuitive. It is definitely a challenge with limited screen real estate. There are so many features packed into this software its hard to find them all.

Perhaps a video walkthru / demo for new users with screen captures? Once I understand it more I can try to do this.

"terminate instead of run in background": personally to do continuous logging, even when I get a phone call or switch apps, is important. So I don't want the program to quit when i switch apps.
the clicking sound happened when

car was not on
car not plugged in

which would be the two situations where the app works.

the clicking starts as soon as the app starts up and tries to connect the ELM.

also, i downloaded the log file but having problems figuring out which app to open it with. Using Open Office and it gives me a list of a dozens of apps to open it with but unable to find anything yet. is it a zip file?

another thing; the 12 volt battery monitor seems to be off. i reset the calibration on it several times already but most of the readings seem to be in the 10 volt range which i have to consider highly unlikely. anyone else having issues with this?
2011 SL; 44,598 miles. 2013 S; 44,840 miles.2016 S30 deceased. 29,413 miles. 2018 S40; 15,000 miles, 478 GIDs, 37.0 kwh 109.81 Ahr , SOH 94.61, Hx 120.15
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

QueenBee
Posts: 1564
Joined: Sun Aug 08, 2010 5:14 pm
Delivery Date: 20 Jun 2011
Leaf Number: 2062
Location: Bellevue (Seattle), WA

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Mon Sep 02, 2013 2:29 pm

DaveinOlyWA wrote:oh one thing i was going to ask you. When i turn on the batt app and LEAF is off, there is a solenoid clicking sound coming from the black box on the right front side on top of the wheel well. what is it?
I have had that clicking sound as well. It doesn't happen all the time and I can't say whether it is when I use the battery app or when I leave the ELM327 plugged in. It doesn't happen all the time.

another thing; the 12 volt battery monitor seems to be off. i reset the calibration on it several times already but most of the readings seem to be in the 10 volt range which i have to consider highly unlikely. anyone else having issues with this?[/quote]

I could never get that dongle to accurately read the voltage. I haven't tried on the new one that Brain P. so kindly converted to be switched (so it turns off when the car turns off).

Here's Phil's response to the clicking which is caused by the LEAF Battery App making requests when the car is off. Quiting the app or unplugging the dongle is the cure but Phil says it is nothing to be worried about.
http://www.mynissanleaf.com/viewtopic.p ... pp#p294195

kevinleaf
Posts: 178
Joined: Mon Jun 03, 2013 4:19 pm
Delivery Date: 03 Jun 2013

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Mon Sep 02, 2013 3:58 pm

also, i downloaded the log file but having problems figuring out which app to open it with.
Which log are you talking about? There is a BatLog.txt which is a comma separated text file (csv) which you should be able to open with Excel or OpenOffice equivalent. You may need to rename it from .txt to .csv to get the program to recognize it correctly. Comma separated, one line per record, unquotated and first line is a list of fields, in case it asks.

DaveinOlyWA
Posts: 14156
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Mon Sep 02, 2013 4:48 pm

kevinleaf wrote:
also, i downloaded the log file but having problems figuring out which app to open it with.
Which log are you talking about? There is a BatLog.txt which is a comma separated text file (csv) which you should be able to open with Excel or OpenOffice equivalent. You may need to rename it from .txt to .csv to get the program to recognize it correctly. Comma separated, one line per record, unquotated and first line is a list of fields, in case it asks.
oh ya! i have been trying to open the wrong file. I have too many files with "Bat" in them!
2011 SL; 44,598 miles. 2013 S; 44,840 miles.2016 S30 deceased. 29,413 miles. 2018 S40; 15,000 miles, 478 GIDs, 37.0 kwh 109.81 Ahr , SOH 94.61, Hx 120.15
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Tue Sep 03, 2013 10:29 am

UkrainianKozak wrote:Few weird things with latest beta...
1. Outside temperature while charging is showing wrong value... almost seems like it is C instead of F (Image 1).
2. The cell voltages display sometimes jumps and fill in fully (Image 2)
3. I have a FastCharger communication problem error code (awesome feature-works!) But Clear DTCs is always disabled for me for some reason, so I can't clear this error code...
4. Not version specific and minor, but when upgrading to new version some (not all) of the settings are getting lost, here's the one I noticed: saved DTE value (red triangle on bottom is always resets to 0, while SOC triangle is saved after installing new version); PSI alarm settings - always resets to 38 and no delta warning.
I took a closer look at issue #2.

It is working as designed. You have selected a 50 mv scale and the data you are trying to view has a 742 mv difference. You will need to select a 1600 mv scale to see all the data otherwise it it will go off the top of the screen which is what you are seeing.

The other option would be to change the program to do a temporary scale change so all the data fits on the screen. You would still have the option to change the scale but it will be ignored if the data does not fit within that scale. When the data does fit the user scale would be used.

How does that sound?

========================

Changed the code to include a temporary scale override function and it looks good so it will be included in the next version. The max auto scale has been changed to 4500 mv so under worst case valid voltage readings the graph will always fit on the screen. If the app gets bad data then it is still possible to go off screen if the max voltage is above 4.5 volts and the lowest is zero.

User avatar
UkrainianKozak
Posts: 355
Joined: Thu May 12, 2011 2:53 pm
Delivery Date: 12 May 2011
Leaf Number: 001065
Location: Redmond, WA

Re: Using clone ELM327 Bluetooth OBDII adapter with Leaf

Tue Sep 03, 2013 7:27 pm

Well, the weirdness of behaviour is that it actually does it for few moments only, it kind of flickers for a second with "filled in" screen and then readjusts to fit the scale automatically somehow
Turbo3 wrote:
UkrainianKozak wrote:Few weird things with latest beta...
1. Outside temperature while charging is showing wrong value... almost seems like it is C instead of F (Image 1).
2. The cell voltages display sometimes jumps and fill in fully (Image 2)
3. I have a FastCharger communication problem error code (awesome feature-works!) But Clear DTCs is always disabled for me for some reason, so I can't clear this error code...
4. Not version specific and minor, but when upgrading to new version some (not all) of the settings are getting lost, here's the one I noticed: saved DTE value (red triangle on bottom is always resets to 0, while SOC triangle is saved after installing new version); PSI alarm settings - always resets to 38 and no delta warning.
I took a closer look at issue #2.

It is working as designed. You have selected a 50 mv scale and the data you are trying to view has a 742 mv difference. You will need to select a 1600 mv scale to see all the data otherwise it it will go off the top of the screen which is what you are seeing.

The other option would be to change the program to do a temporary scale change so all the data fits on the screen. You would still have the option to change the scale but it will be ignored if the data does not fit within that scale. When the data does fit the user scale would be used.

How does that sound?

========================

Changed the code to include a temporary scale override function and it looks good so it will be included in the next version. The max auto scale has been changed to 4500 mv so under worst case valid voltage readings the graph will always fit on the screen. If the app gets bad data then it is still possible to go off screen if the max voltage is above 4.5 volts and the lowest is zero.
Leaf SL-e
Redmond, WA

41 000 electric miles and counting...

Return to “LEAF CANBus”