vegastar
Posts: 208
Joined: Mon Dec 13, 2010 11:29 am
Delivery Date: 07 Jul 2011
Leaf Number: 5564
Location: Portugal

Re: Leaf Spy and Leaf Spy Pro

Sat Mar 03, 2018 1:14 am

Turbo3 wrote:
vegastar wrote:It detected it was a 2018, but with the wrong battery. Maybe the problem is because mine was an european 2018 Nissan Leaf?
European 2018 Leafs should be correctly detected in the next release.

Can you post the first 10 characters of your VIN?
Image
2011 Nissan LEAF since 2011-07-07, 151000 km on 2018-03-03, 7 bars, 37.9Ah.

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Sat Mar 03, 2018 12:44 pm

vegastar wrote:
Turbo3 wrote:
vegastar wrote:It detected it was a 2018, but with the wrong battery. Maybe the problem is because mine was an european 2018 Nissan Leaf?
European 2018 Leafs should be correctly detected in the next release.

Can you post the first 10 characters of your VIN?
Image
Thanks. The next release will correctly identify it as a 2018.

DaveinOlyWA
Posts: 14384
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Leaf Spy and Leaf Spy Pro

Sat Mar 03, 2018 2:29 pm

2018 LEAF with LSP. My odometer has stopped working. It was stuck at 672 for a while and noticed it has moved.... a bit. Should I send you a trace?
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 2640.9 mi, 99.37% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Sat Mar 03, 2018 4:48 pm

DaveinOlyWA wrote:2018 LEAF with LSP. My odometer has stopped working. It was stuck at 672 for a while and noticed it has moved.... a bit. Should I send you a trace?
No, that is caused by a bug clearing the internal flag that indicates a 2018 model. You can try going into Settings while connected to the Leaf and selecting Model Year 2018 again.

===============================
Update:
Actually Yes I need an ELM trace as yours should be a US Leaf with a US VIN so detection of 2018 should be working. It is only the EU Leafs that have the problem.

brycenesbitt
Posts: 114
Joined: Sun Jan 31, 2016 8:48 pm
Delivery Date: 01 Feb 2016

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 1:18 am

Given that the Bluetooth Konnwei KW902 is a knockoff device, of which some are defective, and gets terrible reviews on Amazon.... what's the currently recommended adapter for iOS or Android Leaf Spy? I have the LELink adapter which is supported and real, but does not work on Android Leaf Spy.

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 1:35 am

brycenesbitt wrote:Given that the Bluetooth Konnwei KW902 is a knockoff device, of which some are defective, and gets terrible reviews on Amazon.... what's the currently recommended adapter for iOS or Android Leaf Spy? I have the LELink adapter which is supported and real, but does not work on Android Leaf Spy.
Looking at the top of the clear LELink case, does it have a small superscript 2 after LELink?

Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.

cwerdna
Posts: 9987
Joined: Fri Jun 03, 2011 4:31 pm
Delivery Date: 28 Jul 2013
Location: SF Bay Area, CA

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 1:49 am

Turbo3 wrote: Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.
But it requires the Android phone support Bluetooth LE, right?

Some folks use cheapo prepaid phones like the Kyocera Event for Leaf Spy. It seems like that cheapo phone only supports Bluetooth 2.1 per spec sheet at https://www.kyoceramobile.com/event/ and https://www.phonearena.com/phones/Kyocera-Event_id7733. So, I'm not clear if it supports Bluetooth LE.

If folks have cheapo Android phones w/o Bluetooth LE support...

'19 Bolt Premier
'13 Leaf SV w/premium package (owned)
'13 Leaf SV w/QC + LED & premium packages (lease over, car returned)

Please don't PM me with Leaf questions. Just post in the topic that seems most appropriate.

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 11:24 am

cwerdna wrote:
Turbo3 wrote: Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.
But it requires the Android phone support Bluetooth LE, right?

Some folks use cheapo prepaid phones like the Kyocera Event for Leaf Spy. It seems like that cheapo phone only supports Bluetooth 2.1 per spec sheet at https://www.kyoceramobile.com/event/ and https://www.phonearena.com/phones/Kyocera-Event_id7733. So, I'm not clear if it supports Bluetooth LE.

If folks have cheapo Android phones w/o Bluetooth LE support...
You are correct. You need a phone with BLE support which means Android 4.3 (APi 18) or higher.

I your case you could use the OBDLink LX.

hieronymous
Posts: 35
Joined: Tue Sep 16, 2014 8:54 pm
Delivery Date: 30 Jul 2014
Leaf Number: 200222
Location: Auckland, New Zealand

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 6:18 pm

Hi Turbo3

I am running LSP v0.41.111 (Android). My Leaf doesn’t have TPMS, so I display battery temps on screen 4. In Settings, the alternate display Tire Pressures / Battery Temps checkbox is ticked.

On screen 4, a red overlay with a TPMS warning appears covering the temps/pressures panel, which disappears with a double tap

This red overlay now appears every time I boot LSP (and needs removing), whereas until very recently the display went straight to battery temps, the red overlay having been turned off long ago.

Only two things have changed recently - the update to v0..41.111, and my creating and running custom screens (which seems un-related).

If this issue has already been discussed, please point me to the thread/post - thanks.
Local use only: max. charge 39.0% SoC
Built 05/12, Nissan stockpiled 26 months
07/14: 57km, SOH 96%, AHr 63.37 (new)
07/15: 4032km, 93%, 61.41
07/16: 6628km, 95%, 62.90 (P3227)
07/17: 8742km, 95%, 62.90
07/18: 11355km, 94.8%, 62.22

Turbo3
Gold Member
Posts: 2011
Joined: Mon Jul 19, 2010 8:34 pm
Delivery Date: 12 May 2011
Leaf Number: 002191
Location: San Jose, CA

Re: Leaf Spy and Leaf Spy Pro

Wed Mar 07, 2018 8:22 pm

hieronymous wrote:Hi Turbo3

I am running LSP v0.41.111 (Android). My Leaf doesn’t have TPMS, so I display battery temps on screen 4. In Settings, the alternate display Tire Pressures / Battery Temps checkbox is ticked.

On screen 4, a red overlay with a TPMS warning appears covering the temps/pressures panel, which disappears with a double tap

This red overlay now appears every time I boot LSP (and needs removing), whereas until very recently the display went straight to battery temps, the red overlay having been turned off long ago.

Only two things have changed recently - the update to v0..41.111, and my creating and running custom screens (which seems un-related).

If this issue has already been discussed, please point me to the thread/post - thanks.
If you don't have TPMS why is the "Alternate Tire / Temp Display" ticked? That will cause LeafSpy to alternate between the useless tire pressure screen with the overlay and the temperature screen you want to see.

I would recommend you disable the Alternate function and also the Warn at/below and Delta Warning features. Disable is the top option for both.

If you go back to screen 4 and temperatures are not displayed just tap to switch to it. Then exit the app to save the current configuration. Now each time you start you should only see the temperature display and it will not alternate to tire pressures.

Keep in mind if you do a long tap on the temperature panel you will enable alternate again.

Actually a tap on the tire pressure/temperature panel disables the alternate function and additional taps switches between what is displayed.

If you are seeing the orange tire message over the temperature readings please send me a screenshot as that should not happen.

Return to “LEAF CANBus”