Page 177 of 208

Re: Leaf Spy and Leaf Spy Pro

Posted: Sat Mar 03, 2018 1:14 am
by vegastar
Turbo3 wrote:
vegastar wrote:It detected it was a 2018, but with the wrong battery. Maybe the problem is because mine was an european 2018 Nissan Leaf?
European 2018 Leafs should be correctly detected in the next release.

Can you post the first 10 characters of your VIN?
Image

Re: Leaf Spy and Leaf Spy Pro

Posted: Sat Mar 03, 2018 12:44 pm
by Turbo3
vegastar wrote:
Turbo3 wrote:
vegastar wrote:It detected it was a 2018, but with the wrong battery. Maybe the problem is because mine was an european 2018 Nissan Leaf?
European 2018 Leafs should be correctly detected in the next release.

Can you post the first 10 characters of your VIN?
Image
Thanks. The next release will correctly identify it as a 2018.

Re: Leaf Spy and Leaf Spy Pro

Posted: Sat Mar 03, 2018 2:29 pm
by DaveinOlyWA
2018 LEAF with LSP. My odometer has stopped working. It was stuck at 672 for a while and noticed it has moved.... a bit. Should I send you a trace?

Re: Leaf Spy and Leaf Spy Pro

Posted: Sat Mar 03, 2018 4:48 pm
by Turbo3
DaveinOlyWA wrote:2018 LEAF with LSP. My odometer has stopped working. It was stuck at 672 for a while and noticed it has moved.... a bit. Should I send you a trace?
No, that is caused by a bug clearing the internal flag that indicates a 2018 model. You can try going into Settings while connected to the Leaf and selecting Model Year 2018 again.

===============================
Update:
Actually Yes I need an ELM trace as yours should be a US Leaf with a US VIN so detection of 2018 should be working. It is only the EU Leafs that have the problem.

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 1:18 am
by brycenesbitt
Given that the Bluetooth Konnwei KW902 is a knockoff device, of which some are defective, and gets terrible reviews on Amazon.... what's the currently recommended adapter for iOS or Android Leaf Spy? I have the LELink adapter which is supported and real, but does not work on Android Leaf Spy.

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 1:35 am
by Turbo3
brycenesbitt wrote:Given that the Bluetooth Konnwei KW902 is a knockoff device, of which some are defective, and gets terrible reviews on Amazon.... what's the currently recommended adapter for iOS or Android Leaf Spy? I have the LELink adapter which is supported and real, but does not work on Android Leaf Spy.
Looking at the top of the clear LELink case, does it have a small superscript 2 after LELink?

Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 1:49 am
by cwerdna
Turbo3 wrote: Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.
But it requires the Android phone support Bluetooth LE, right?

Some folks use cheapo prepaid phones like the Kyocera Event for Leaf Spy. It seems like that cheapo phone only supports Bluetooth 2.1 per spec sheet at https://www.kyoceramobile.com/event/ and https://www.phonearena.com/phones/Kyocera-Event_id7733. So, I'm not clear if it supports Bluetooth LE.

If folks have cheapo Android phones w/o Bluetooth LE support...

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 11:24 am
by Turbo3
cwerdna wrote:
Turbo3 wrote: Which version of LeafSpy are you running ? LeafSpy or LeafSpy Pro?

The LELink is the recommended adapter for both iOS and Android.
But it requires the Android phone support Bluetooth LE, right?

Some folks use cheapo prepaid phones like the Kyocera Event for Leaf Spy. It seems like that cheapo phone only supports Bluetooth 2.1 per spec sheet at https://www.kyoceramobile.com/event/ and https://www.phonearena.com/phones/Kyocera-Event_id7733. So, I'm not clear if it supports Bluetooth LE.

If folks have cheapo Android phones w/o Bluetooth LE support...
You are correct. You need a phone with BLE support which means Android 4.3 (APi 18) or higher.

I your case you could use the OBDLink LX.

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 6:18 pm
by hieronymous
Hi Turbo3

I am running LSP v0.41.111 (Android). My Leaf doesn’t have TPMS, so I display battery temps on screen 4. In Settings, the alternate display Tire Pressures / Battery Temps checkbox is ticked.

On screen 4, a red overlay with a TPMS warning appears covering the temps/pressures panel, which disappears with a double tap

This red overlay now appears every time I boot LSP (and needs removing), whereas until very recently the display went straight to battery temps, the red overlay having been turned off long ago.

Only two things have changed recently - the update to v0..41.111, and my creating and running custom screens (which seems un-related).

If this issue has already been discussed, please point me to the thread/post - thanks.

Re: Leaf Spy and Leaf Spy Pro

Posted: Wed Mar 07, 2018 8:22 pm
by Turbo3
hieronymous wrote:Hi Turbo3

I am running LSP v0.41.111 (Android). My Leaf doesn’t have TPMS, so I display battery temps on screen 4. In Settings, the alternate display Tire Pressures / Battery Temps checkbox is ticked.

On screen 4, a red overlay with a TPMS warning appears covering the temps/pressures panel, which disappears with a double tap

This red overlay now appears every time I boot LSP (and needs removing), whereas until very recently the display went straight to battery temps, the red overlay having been turned off long ago.

Only two things have changed recently - the update to v0..41.111, and my creating and running custom screens (which seems un-related).

If this issue has already been discussed, please point me to the thread/post - thanks.
If you don't have TPMS why is the "Alternate Tire / Temp Display" ticked? That will cause LeafSpy to alternate between the useless tire pressure screen with the overlay and the temperature screen you want to see.

I would recommend you disable the Alternate function and also the Warn at/below and Delta Warning features. Disable is the top option for both.

If you go back to screen 4 and temperatures are not displayed just tap to switch to it. Then exit the app to save the current configuration. Now each time you start you should only see the temperature display and it will not alternate to tire pressures.

Keep in mind if you do a long tap on the temperature panel you will enable alternate again.

Actually a tap on the tire pressure/temperature panel disables the alternate function and additional taps switches between what is displayed.

If you are seeing the orange tire message over the temperature readings please send me a screenshot as that should not happen.