Page 32 of 47

SOH value is zero. Why?

Posted: Sat Oct 07, 2017 4:21 pm
by tomgilman
I understood the SOH value to be one of the key easier to understand values, but mine is zero. Not sure what this means. I see the screenshot on the iTunes app store also has a value of zero. Any hints or suggestions are appreciated.

Re: iOS LeafSpy Pro Support

Posted: Sat Oct 07, 2017 10:38 pm
by alozzy
What OBD2 dongle did you purchase? Sounds like the OBD2 dongle isn't communicating with the iPhone, so LeafSpy isn't pulling any real data.

Re: SOH value is zero. Why?

Posted: Sat Oct 07, 2017 10:47 pm
by Turbo3
tomgilman wrote:I understood the SOH value to be one of the key easier to understand values, but mine is zero. Not sure what this means. I see the screenshot on the iTunes app store also has a value of zero. Any hints or suggestions are appreciated.
Take an ELM trace and send it to me. See bottom of help file for how to do it.

If you are testing on a 2018 Leaf you will need to use a test version to see SOH.

Re: iOS LeafSpy Pro Support

Posted: Thu Oct 12, 2017 2:10 am
by willmkz
Hi,

I am a new LeafSpy Pro user and am having trouble connecting to my iPhone. Please would you let me know where I am going wrong?

I am using the OBD II wifi dongle below:

https://www.amazon.co.uk/Pumpkin-Interf ... dongle+ios

I have used IP adress: 192.168.0.123
I have used Subnet Mask: 255.255.255.0

Following the instructions I receive a yellow box in the bottom right corner and with the leaf turned on I receive the "Retry ELM 00" Error code. Note that the app connects to the dongle and WiFi_OBDII is visible at the bottom of the screen.

I left the connection open whilst driving to work, and the error changed to "Retry ELM 11".

Is there any obvious mistake that you are aware of that could cause this?

Many thanks,

Will

Re: iOS LeafSpy Pro Support

Posted: Thu Oct 12, 2017 10:17 am
by Turbo3
willmkz wrote:Hi,

I am a new LeafSpy Pro user and am having trouble connecting to my iPhone. Please would you let me know where I am going wrong?

I am using the OBD II wifi dongle below:

https://www.amazon.co.uk/Pumpkin-Interf ... dongle+ios

I have used IP adress: 192.168.0.123
I have used Subnet Mask: 255.255.255.0

Following the instructions I receive a yellow box in the bottom right corner and with the leaf turned on I receive the "Retry ELM 00" Error code. Note that the app connects to the dongle and WiFi_OBDII is visible at the bottom of the screen.

I left the connection open whilst driving to work, and the error changed to "Retry ELM 11".

Is there any obvious mistake that you are aware of that could cause this?

Many thanks,

Will
When you get to state ELM 11 you have connected to the WiFi OBDII adapter but the adapter is not receiving data from the Leaf. This is normally because the Leaf in not on (dash gauges active) but since you were driving that is not the case. The leaves two other possibilities. One is the adapter does not support the needed commands and the other is a defective OBDII adapter. In either case I will need to see an ELM trace. For instructions on how to take an ELM trace see the bottom of the Help file. Send the trace (TRC_xxxx.txt) file to the contact address below.

Issues with iOS 11?

Posted: Wed Oct 18, 2017 8:34 am
by JeffInCO
Is anyone having issues with LeafSpy Pro, BLE OBD adapters, and iOS 11?

I have an LE Link BLE OBD adapter that has worked great for over a year.

I hadn't used LeafSpy for a week or two after updating my iPhone6 to iOS11. The next time that I tried to open LeafSpy, it's as if it doesn't attempt the BLE connection. (I see "WiFi NC" in yellow on the bottom right of the screen.)

Bluetooth is definitely enabled... I regularly stream audio via BT to my Leaf.

I suppose it's possible that my LE Link died around the same time that I upgraded to iOS11, but that's unlikely. (FWIW, the LE Link still lights up red.)

Any tips?

Thanks,

Jeff

Re: iOS LeafSpy Pro Support

Posted: Mon Oct 23, 2017 1:15 pm
by murduc2
Did you try unplugging your adapter and plugging it back in? Every once in awhile I have to do that.

Re: iOS LeafSpy Pro Support

Posted: Mon Oct 23, 2017 1:17 pm
by murduc2
Is there an update coming soon to iOS that fixes the DropBox disconnected issue?
*fingers crossed*

Re: iOS LeafSpy Pro Support

Posted: Mon Oct 23, 2017 9:39 pm
by JeffInCO
A reset of my iPhone (hold down home and power) seemed to fix the problem.

Before that, I did try unplugging/replugging the adapter, which didn't help.

In any case, I'm back up and running again.

Thanks!

Jeff

Re: iOS LeafSpy Pro Support

Posted: Mon Oct 23, 2017 11:40 pm
by Turbo3
murduc2 wrote:Is there an update coming soon to iOS that fixes the DropBox disconnected issue?
*fingers crossed*
If you send me a request I can add you to the iOS testers group which has a version with the Dropbox fix.