2016 Tekna I-Key error, car won't turn off

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Dec 9, 2022
I drove the car yesterday on a short journey, when I arrived at the destination the car displayed an I-Key error and wouldn't turn off.
Drove home and pulled the 12v battery to kill it.

Replaced the 12v battery with a fully charged new one, same problem. Used leafspy pro/battery disconnect to clear errors but they kept coming back. Now when I disconnect the 12v battery the car stays on, I have to pull the HV fuse to kill it. Also the car will no longer go into forward or reverse, just park and neutral.

Below is the latest output from leafspy pro. Anything I can check before it gets towed to a garage?

>C118C 0109 ABS EV/HEV System BRC-126
Ok None ---> AIR BAG
U1000 0008 BCM CAN Comm Circuit
U0415 0008 BCM Vehicle Speed BCS-68
>B2557 0009 BCM Vehicle Speed SEC-74
>B2604 0009 BCM Shift PN Diag CAN SEC-81
>B26F2 0009 BCM IGN Relay On Stuck PCS-61
B26E7 0008 BCM
>C1A6E 0109 BRAKE EV/HEV System BR-146
>C1A70 0109 BRAKE Brake Control System BR-160
>U1000 0109 BRAKE CAN Comm Circuit
>U1510 0109 BRAKE Brake Control Comm BR-177
Ok None --> CHARGER
Ok None --> EPS
>P3101 000B EV/HEV VCM EVC-200
P3194 000A EV/HEV CAN Error EVC-270
>P3187 O00B EV/HEV Elec Shift System EVC-257
>U1000 000B EV/HEV CAN Comm Circuit
P31B7 000A EV/HEV CAN Error EVC-285
>P1574 000B EV/HEV ASCD Vehicle Speed Sensor EVC-185
>P1612 000B EV/HEV Chain of VCM-IMMU SEC-60
Ok None ---> HVAC
Ok None ---> IPDME/R
Ok None --> METER
Ok None--> MULTI AV
P1811 000A SHIFT Elec Shift Pwr Supply Relay TM-79
U1000 0O0A SHIFT CAN Comm Circuit
Ok None --> TCU
Ok None---> VSP
Ok None -> AVM
Was there any interesting outcome of the problem above from dec 2022?

I now have very similar symptoms with my 2015 24kWh tekna. The original problem was that the car would not properly shut down at the end of a trip, I got the same I-Key error, and an error claiming that the parking brake was not on when it was on, both shown on the car's display.
I disconnected the 12V battery to get it to shut down, and charged, then replaced the 12V battery.
Many DTCs occur after disconnecting and reconnecting the 12V battery.
By clearing as many as possible, I got a much smaller stable set.
My most significant one seems to be P317A-00 ev/hv motor system (inverter voltage too high – I think that means it has voltage when it should not during startup)
Currently it seems rather likely that the main contactors in the traction battery pack are stuck on. That might explain the not shutting down properly, and I also measure 372V across the service link contacts of the traction battery when the 12V is disconnected, which seems to me to be wrong if the main contactors were opening as they should.
I've found on many Leaf 12v replacement jobs, as you did, that there can be many many fault codes...... I've also found that some fault codes are caused by other codes 'lower down' the LeafSpy list - when I encounter troublesome deletes, I skip the troublesome one, to delete all the 'lower' ones, then invariably the troublesome one will clear, too, after the rest have been deleted ...... please try this, and let me know if it works as well for you as it invariably does for me :)
Yes I had done that process of clearing codes and then going back to the ones that did not clear first time and trying again. I am just talking about the codes that are left: I have a few for brake and air bag that I think occur because the start sequence does not finish, and I have the P317A mentioned above. Also I have tried several 12V batteries including one brand new and fully changed and I frequently check the actual voltage is >12V so my problems are not caused by a low/weak 12V battery (at least not any more, I guess it's possible that they first started due to a 3 year old battery though that still seems to hold a reasonable voltage.)
My problem was due to the main relays in the battery being stuck on. Replacing the relays solved the problem. This is a job with a significant level of difficulty and danger. Used relays cost me £100 and I will have spent around 20 hours working on it by the time I finish. I guess I would have had to pay a professional for around 10 hours of labor if I did not do it myself. I do not know what caused the relays to stick on in the first place. I guess the most likely reason would be failure of the pre-charge relay or resistor, but they seemed to be working fine. I can hear a sensible number of clicks in the battery now when switching on or off, 2 loud clicks from the main relays and at least one quieter click from the pre-charge relay.
I do not know what caused the relays to stick on in the first place.
My theory on this is that the old, weak or worn out 12V battery failed to hold up the system voltage while the Pack was under load (driving or charging).

The 12V is needed to engage the relays aka Main Contactors in the Pack. The closing and opening of these Contactors is controlled by the EV-ECU to only occur when there is no current load (zero Amps).

If the Contactors are accidentally opened while current is flowing then a big arc will occur across the internal contacts, and it is likely that the precious metal surface of the contacts will be damaged or welded together.
Although my main relays actually were stuck on and I replaced them and the car then worked OK, my problem came back. Not the relays sticking, but the "will not turn off" problem, with similar DTCs to those in the original post of this thread.
After a long time looking for possible causes of CAN communication faults, and not finding anything, it started working again. I still don't know why. Now I have to try and overcome the fear that it will happen again and leave me stranded.
When the problem happens, I have to disconnect the 12V battery to get the car to turn off, then when I reconnect I get many DTCs and the car will not properly turn on. Perhaps I've been doing everything too fast? Next time I will try shutting the doors, waiting 5 mins, disconnect the 12V, wait 5 mins, reconnect 12V, wait 5 mins, open the door, turn on without pressing the brake, clear as many DTCs as possible, turn off, turn on.
Disconnecting/reconnecting the 12V seems very brutal. It would be nice if it was possible to do a reboot, without disconnecting the power from every ECU.
Update. The problem seemed to be water ingress to the BCM connectors. See my post "Will not turn off, various DTCs, I-key system error, parking brake error"
Last edited: