Air conditioning works but won't run

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Jun 7, 2023

Having a weird issue with climate control in my 2011 Leaf and wondering if anyone here has seen something similar.

The air conditioning works perfectly fine, but only some of the time. When it runs I get plenty of cold air. However the system seems to be choosing not to run much of the time even when it's quite hot. I have the temperature set as low as it will go (60 F) and it's 100+ F in the car, AC not running. I have watched the energy monitor screen, and I can see when it's blowing hot air that the climate control isn't using much power - I see it jump up right away when the AC compressor does decide it wants to run.

I've owned this car for about a year and half now and this issue only started in the last month or so. It happens intermittently but more often than not now. Sometimes it will blow hot when I first turn the car on but start to cool off after a few minutes, which sometimes lasts and sometimes does not; other times it starts cold but randomly goes back to hot mid-drive. I have not been able to correlate it to ambient temperature, day/night, or anything else.

My first thought is that it was an issue with the in-car temperature sensor. I dug into the service manual and saw it could be a few other parts as well though, notably the intake sensor / "evaporator cryoprotective protection control" logic. In either case the thinking is that a bad sensor reading is tricking the control system into thinking it's already cool enough (if it's the in-car sensor) or too cold to run the evaporator without damage (cryoprotective logic).

No warning lights or any indication of issues. Unfortunately I have not had any luck reading DTCs or sensor values via ODBII. I have tried two adapters now, one Bluetooth and one USB, and was not able to get either to even make a connection to the vehicle using any of the software programs and apps I tried (both an Android phone and a Linux laptop). I can keep buying and returning OBDII interfaces and hoping I get lucky but I'm not holding my breath.

Trying to avoid having to take it to the dealer since it will inevitably turn into hundreds of dollars for what's probably a really simple fix if I knew what to do.

Anyone seen something like this before? Alternatively can anyone recommend a specific OBDII adapter and software / app that actually works with the Leaf (and has been recently purchased, in 2023, and known to work)?

Why would you think it's anything but a failure in the A/C system? This is something that any competent shop (doesn't have to be a dealer) can diagnose. Unless you discover some specific DTC codes via LeafSpy (there are plenty of threads on dongles/LeafSpy).
LeftieBiker, thanks for the suggestion, I'll give that one a try.

Stanton, I'll be taking it to a repair shop soon if I can't get any further with this on my own, but the symptoms suggest to me it's on the control side rather than the mechanical side of the AC system. Granted I am certainly no expert, which is why I came here :)

It's entirely possible there are some DTCs lurking to the effect of "go replace your whole AC now please" and it just fails silently without any warning lights or on-screen messages. I would hope the system would be a bit more helpful than that if there were a detectable major failure, but you never know. I'm hoping to at least get as far as getting OBDII working checking for DTCs myself before I take it to a professional.
As a reminder, you cannot use "normal" scanners or diagnostic software with the LEAF. You need LEAF Spy Pro (available for both Android and iPhone) with a suitable Bluetooth adapter. Check the threads regarding LEAF Spy for more information. I agree, the issue is likely a sensor or control system issue since it gets cold some of the time.
Wanted to follow up on this since I made some progress. Thanks for your replies - I was able to get LeafSpy Pro working with the dongle suggested and read the DTCs.

There were four DTCs from the AC system:
  • B2582 0008 HVAC Intake Sensor HAC-69
  • B278C 0008 HVAC Comp Comm Err HVAC->Comp HAC-103
  • B2786 0008 HVAC Comp IPM Discharge Temp Limit HAC-96
  • B2790 0008 HVAC Heater Pump Comm H/P->HVAC HAC-107

Being quite an old car I'd expect to see all manner of DTCs listed from random transient issues (and indeed there were plenty besides the HVAC ones). To diagnose further, I cleared the HVAC DTCs and waited to see which if any came back.

Ironically, simply clearing the DTCs made the system a lot happier, the AC has been working pretty reliably. Go figure. Been about five days now, in one instance the air blew hot at startup but got cold again within a couple minutes, and the rest of the time it starts up cold right away.

I re-checked the DTCs this evening, and one had returned: B2582 0008 HVAC Intake Sensor HAC-69. So it looks like I was right, there's an issue with the intake sensor that's activating the cryoprotective logic and preventing the compressor from running in some instances.

Based on the service manual that unfortunately is not something mere mortals can repair, you need to pull the whole AC unit (including capturing the refrigerant and refilling it afterwards) just to get to the sensor in question. So I'll be taking it to the shop to get this sorted out for good, but at least for the moment the issue is under control, and now I know exactly what to have them look at.

Thank you again to everyone who chimed in, much appreciated!
I have a similar problem where my AC occasionally does not turn on, especially when the outside temp is between 85 - 95 F. I ran LeafSpy and I get only one HVAC DTC -- the B2582 0008 HVAC Intake Sensor HAC-69. How did you solve your issue?
Could be as simple as dirty connection on the sensor harness plug. The evaporator is a wet environment. Not sure if it's possible to reach the connector without removing the evaporator but if it is, simply unplugging and re-plugging the harness connector multiple times might improve things.
Been meaning to post an update on this since it's been working since my fix a couple months ago.

Unfortunately it's not possible to reach the connector or the sensor without taking apart the whole AC unit. Long story short, after trying several repair shops who couldn't handle the special lubricant in the refrigerant, another with the right equipment who refused to help since they couldn't diagnose it themselves, and the dealer quoting me over $2k for the repair, I decided to take things into my own hands.

I simply removed the dash panel around the MFD in the front to access the AC auto amp, cut the wire that goes to the intake sensor, and soldered in a fixed resistor between that wire and ground, so the control system always reads a happy value and won't shut off the compressor.

To be clear, I don't recommend anyone do this unless you fully understand what you're doing and what the risks are, the cryoprotective logic is there for a reason, but in my case I didn't have much to lose. Worst case the AC still didn't work but best case I save a very expensive repair and get a little more use out of this old car.

I used a 3.9k resistor, based on this plot from the service manual that keeps it permanently reading around 9-10ºC.


This is what it looked like before I taped it back up. Resistor went between pins 34 (green - cut wire to sensor) and 30 (red - ground).


Took about 20 minutes total and it's been working great ever since, nice cold air.
I Just did this sensor bypass myself, however, no cold air.  Put a pressure gauge on the low side of the AC, and it pegs out high on the gauge.  Does this mean the compressor is not engaging at all still? Running LeafSpy yields no DTC's...

BTW, the pic for the rewiring has the connector “upside down”, relative to where it goes into the MFD. Would post a couple pics but don't have a URL to host there a free one?
Graylens back again, it's June in Phoenix and I still have the Leaf and the AC is out.

duckyducky9999, this "intake sensor" we are fooling -- is that temperature just for the onboard computer to think it's "safe" to turn on the compressor? That's not what it thinks what the cabin temperature is?​

If you're still in Phoenix I'll buy you a six-pack of your favorite beverage and you can examine my solder job, I'm about to rip everything out and try again...
Graylens - are you sure this isn't a freon problem? A pressure switch somewhere? Did you add too much Freon? Don't mind me - I don't know much about a/c systems. Does the cabin temp switch just need to be replaced (mentioned in duckyducky9999's post)?

A problem I have with many topics is picking the most complicated or expensive solution when the simple solution to the problem is right in front of me.

KISS - keep it simple stupid - was written for me.

Case in point: my youngest's SUV was losing coolant. I had just changed the water pump b/c it was worn out. Still losing coolant somewhere. Vision of head gasket replacement, and all sorts of expensive problems. Bought a $100 cooling system test kit that includes a radiator cap adapter and a hand pump. Pump it up to the cap pressure and look for leaks. I did and immediately the top hose slid 1/2 way off and started leaking at a gap on the bottom side. Solution: tighten the upper hose clamp more.

Well at least I didn't take it to a shop with a $150 per hour shop rate.
It's most likely not a R-134 (or variant the Leaf uses) problem because my AC sometimes works great, then sometimes not at all.