OBD-II Bluetooth Connection Problems?

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Well-known member
Dec 21, 2012
Bellingham, WA, US
I know several folks on this forum including Jim and Gary have done lot of work reverse engineering the CAN bus. I have been interested in this work and spent some time a while back reading the very old threads where some of the original stuff was worked out, including what we now call "Gids".

My wife and I have gone through three LEAFs now and very frequently use Leaf Spy Pro. She has now got a Kia Soul EV, and I'm interested in spending some time to reverse engineer its CAN buses as well.

However, I'm having some difficulty that I was hoping some of you might be able to help with.

For now I'm just trying to get CAN data from the LEAF, because it's already been done, so I can look back and learn from what others have done, before I move on to the Soul.

I have two cheap ELM327 OBD-II-Bluetooth adapters from Amazon. They both work great with Leaf Spy.

However, I can't get either of them to work with anything else. I've tried Bluetooth serial terminal apps on Android, even one called Elm327 OBD Terminal, and I have tried at least 8 different terminal emulators and OBD-II programs for Windows, and I can't get any of them to even connect to the ELM327 Bluetooth device. I can pair with it just fine on Android and Windows, and, again, Leaf Spy communicates with it on Android. But I can't get any terminals or other OBD-II software to touch it.

Is it possible that Leaf Spy leaves the adapters in a weird state that other serial communication apps don't understand? Or is there something else weird going on?

This is pretty frustrating because I've found several sites explaining how to do this and it's very straightforward to just connect a terminal emulator to the ELM327 over Bluetooth and start entering commands. Mine just don't want to work!

Any suggestions?

Thanks so much!

FYI, I purchased another OBD-II adapter from Amazon, identical to one of my other ones, and it works fine with any terminal app or any other OBD-II app (Torque etc). The ones that I have previously used with Leaf Spy continue to ONLY work with Leaf Spy. Having spent some time now with the ELM327 interface, I'm not entirely sure what Leaf Spy could be doing to cause it to stop working with other apps, but it sure seems that's what happened.