berferd
Posts: 9
Joined: Mon Jul 20, 2020 2:26 pm
Delivery Date: 20 Jul 2020
Location: Colorado, USA

Re: Leaf Spy and Leaf Spy Pro

Fri Aug 21, 2020 3:15 pm

Successfully set up Leaf Spy Pro v0.45.150 today on a 2019 SV Plus with this ODBII scan tool on a Pixel 2XL running Android 10:

https://www.amazon.com/gp/product/B005N ... UTF8&psc=1

NOTE: I purchased the scan tool in 2013.

Android Auto works just fine while using Leaf Spy Pro.
2019 LEAF SV Plus

BLevitan
Posts: 1
Joined: Thu Dec 17, 2020 8:57 am
Delivery Date: 17 Dec 2020
Leaf Number: 014344

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 17, 2020 9:20 am

Sorry if these issues have already been addressed but I did a search and couldn't find anything.

Issue 1: LeafSpy Pro not connecting.
I have the recommended LELink OBDII device and my Android tablet shows it can see the device OK. When I start LeafSpy Pro it shows a connecting message with a "spinner" (really just alternates between / and \) at the bottom right of the screen and shows "LELink" in the bottom centre. But it fails to connect (I have waited over 5 minutes). It has worked in the past, so I'm not sure what's going wrong. I have tried clearing the application cache and forcing the application to stop; I have also tried a restart on the tablet all to no avail. Any ideas how to fix this? Is there a "right" sequence to do things, I have been doibng this: (1) plug in LELink, (2) turn on Leaf, (3) turn on tablet, (4) turn on Bluetooth and check LELINK device is seen, (5) start LeafSpy Pro.

Issue 2: On the two previous occasions I have connected successfully I get all the information screens, but the odometer reading is wrong (by a very large margin). What's going on?

Many thanks for any advice that can be offered.

DaveinOlyWA
Posts: 15330
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 17, 2020 10:53 am

BLevitan wrote:
Thu Dec 17, 2020 9:20 am
Sorry if these issues have already been addressed but I did a search and couldn't find anything.

Issue 1: LeafSpy Pro not connecting.
I have the recommended LELink OBDII device and my Android tablet shows it can see the device OK. When I start LeafSpy Pro it shows a connecting message with a "spinner" (really just alternates between / and \) at the bottom right of the screen and shows "LELink" in the bottom centre. But it fails to connect (I have waited over 5 minutes). It has worked in the past, so I'm not sure what's going wrong. I have tried clearing the application cache and forcing the application to stop; I have also tried a restart on the tablet all to no avail. Any ideas how to fix this? Is there a "right" sequence to do things, I have been doibng this: (1) plug in LELink, (2) turn on Leaf, (3) turn on tablet, (4) turn on Bluetooth and check LELINK device is seen, (5) start LeafSpy Pro.

Issue 2: On the two previous occasions I have connected successfully I get all the information screens, but the odometer reading is wrong (by a very large margin). What's going on?

Many thanks for any advice that can be offered.

Connection issues; unplug OBD, then reconnect.

Odo issues; go to settings enable CAN odo in miles.
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 16,686 mi, 92.44% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

Glyndwr1998
Posts: 29
Joined: Mon Nov 23, 2015 4:50 pm
Delivery Date: 23 Nov 2016
Location: UK, South Wales

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 10:45 am

Hi all,

I have a particular issue.
I`m using a good version of the konweii adaptor and a galaxy note 8, running android 9 i believe.

Loaded are the leafspy free and paid for leafspy pro app.

When i connect to the nissan leaf using the pro app, the connection drops out alll the time and reconnets... this is constant, maybe every 30 seconds.

When i connect to the leaf using the free leafspy app, it connects and stays connected, very stable.

Any idea how i can get around this to ensure the pro version connects and stays as stable as the standard free version.

Many thanks

DaveinOlyWA
Posts: 15330
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 10:51 am

Glyndwr1998 wrote:
Thu Dec 31, 2020 10:45 am
Hi all,

I have a particular issue.
I`m using a good version of the konweii adaptor and a galaxy note 8, running android 9 i believe.

Loaded are the leafspy free and paid for leafspy pro app.

When i connect to the nissan leaf using the pro app, the connection drops out alll the time and reconnets... this is constant, maybe every 30 seconds.

When i connect to the leaf using the free leafspy app, it connects and stays connected, very stable.

Any idea how i can get around this to ensure the pro version connects and stays as stable as the standard free version.

Many thanks
I am guessing car is off when this happens? I have the same issues when the car is off, no issues if the car is on. I think the added complexity of Pro is the likely cause and I no no way to get around it. The other thing is my OBD times out and powers down. Guessing it takes its queue from the car and not the app.
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 16,686 mi, 92.44% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

Glyndwr1998
Posts: 29
Joined: Mon Nov 23, 2015 4:50 pm
Delivery Date: 23 Nov 2016
Location: UK, South Wales

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 3:05 pm

hi Dave,

My leafspy pro is unstable with the car on or off to be honest.

I have a e-nv200 nissan electric van too that the same happens, so i`m pretty sure its a compatibility issue, was hoping someone could give info of maybe a set up change.

I use mostly the free version for everyday use, and only use the pro to read and erase codes (if needed)

Thanks for replying anyway buddy.

DaveinOlyWA
Posts: 15330
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 3:15 pm

Glyndwr1998 wrote:
Thu Dec 31, 2020 3:05 pm
hi Dave,

My leafspy pro is unstable with the car on or off to be honest.

I have a e-nv200 nissan electric van too that the same happens, so i`m pretty sure its a compatibility issue, was hoping someone could give info of maybe a set up change.

I use mostly the free version for everyday use, and only use the pro to read and erase codes (if needed)

Thanks for replying anyway buddy.
Interesting. Konwei has had such a bad rep, hard to discount it but I would also look at the Android version. Version 9 is like ancient... When my LSP fails to load screens its always because an update is available. I normally run LSP on my spare phone which live in airplane mode most of the time so its not updated but somehow LSP still knows...
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 16,686 mi, 92.44% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

ClarD
Posts: 32
Joined: Mon May 02, 2016 8:17 pm
Delivery Date: 06 Apr 2016

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 4:08 pm

Somewhere, if you look in help, there is something about auto-shutoff for the LE-Link.
Maybe for your adapter, that needs to be disabled.

DaveinOlyWA
Posts: 15330
Joined: Sat Apr 24, 2010 7:43 pm
Delivery Date: 16 Nov 2019
Leaf Number: 319862
Location: Olympia, WA
Contact: Website

Re: Leaf Spy and Leaf Spy Pro

Thu Dec 31, 2020 5:27 pm

ClarD wrote:
Thu Dec 31, 2020 4:08 pm
Somewhere, if you look in help, there is something about auto-shutoff for the LE-Link.
Maybe for your adapter, that needs to be disabled.
In settings, there is a checkbox "LeLink^2 Zero Power Mode" but he isn't using that so...dk. I guess it wouldn't hurt to disable it to see if it does anything?
2011 SL; 44,598 mi, 87% SOH. 2013 S; 44,840 mi, 91% SOH. 2016 S30; 29,413 mi, 99% SOH. 2018 S; 25,185 mi, SOH 92.23%. 2019 S Plus; 16,686 mi, 92.44% SOH
My Blog; http://daveinolywa.blogspot.com" onclick="window.open(this.href);return false;

Return to “LEAF CANBus”