CHAdeMO not working

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Well-known member
May 25, 2022
Dala on YouTube suggested I start a new thread for this. I have a 2012 Leaf and the CHAdeMO chrager has never worked since I bought it a year ago. Nissan want me to drive 80 miles and charge me £250-3000 to diagnose and/or fix it, and it could take 3-6 weeks. According to LeafSpy I used to have several CHARGER DTC codes: B29C1 3168 and 2368 (EVSE VC98), B2802 2368 (Q/CHG Isolation Sig Err VC-56), and B2820 0028 (Quick Charger VC-63). But when I checked LeafSpy this week it had no CHARGER codes and said Ok None - Charger. I have not tried using the CHAdeMO for months, so maybe the codes have just disappeared because I haven't tried the CHAdeMO and they will come back if I do. In any case, does anyone have any idea what I need to look at to set about solving this issue? What do these codes refer to and is there anything I might be able to do myself to sort this? Someone suggested corrosion behind the port, but I've taken apart what I can and can't find any. I have been unable to disconnect the connector from the CHAdeMO port where the cables go into the motor housing behind the port to check for corrosion there. Any suggestions gratefully received as I'm trying to sell the vehicle and no one is interested unless I get this fixed.
I should also add that I have various other DTCs showing on LeafSpy: 3 ABS codes, 5 BCM codes, 4 BRAKE codes, 1 HV Battery code (B2109 0008 IPDM/ER), 6 Multi AV codes and 1 TCU code (U1A05 0008 TCU USB Comm AV-199. More info given if needed.
Did you check your 12V battery? If this is in poor condition, you can get a variety of error codes.

I have had some issues with fast charging myself, but it seems ok now after I cleaned the connectors in the Chademo-port. I don't fast charge that often, so I don't want to be too confident that I have fixed it though.
12V battery was replaced 8 months ago. This problem pre-dates that. It's not just error codes: it's that the CHAdeMO actually doesn't work. The charger tells me there is an initialization problem on the vehicle side.