Was my English conversion software wrong?

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Jan 18, 2023
When I purchased my JDM 2017 X30 leaf, the head unit and dash were all in Japanese. As a condition of the sale (in New Zealand) the dealer had everything converted to English, including - although I will never use it - NZ GPS maps. However, there are a few oddities, that may be related to the conversion, or may be how Leafs work - this is my first.

When you turn on the cruise control you have to carefully move the button to engage. If you press it down, the horn honks. Is this normal?

The battery charger allows programming, so I set it to turn on at 11 p.m., but when I plugged it in midday, I found it had charged and was done by 6 p.m.

I set the program to stop at 80%, but the next morning on overnight charge, it read 100%. I had understood on the 30 kWh Leafs, the 80% was taken away, so I am wondering if the conversion people used a conversion for an earlier model that gives the options, but does not execute them when applied.

I purchased an LELink dongle that just arrived from Amazon. The red light goes on, but it does not connect using LeafSpy Lite or LELink Config. I've not yet purchased LeafSpy Pro as I want to make sure the hardware works. I was able to use my Autel MP808 to read and clear errors, but it does not have the specific useful information life LeafSpy.

All of these may be unrelated, and some may be normal, but I would appreciate advice.
  • Is it normal for the horn to honk when pressing the cruise control button?
  • Do I have an incompatible conversion for an earlier era Leaf?
  • How do I make the LELink dongle work with LeafSpy Lite?
It gets worse...

Dear KSolutions Support

I received my LELink^2 Configurable Auto On/Off Bluetooth Low Energy BLE OBD-II OBD2 Car Diagnostic Tool for iPhone/iPod/iPad and Android today from Amazon.

I put it in my 2017 Nissan Leaf. The red light came on. The LeLink app for Android said “connecting” but never connected (see screenshot below). I tried it using iPhone. No connection. I tried LeafSpy Lite, no connection (see screenshot below). I tried looking on Bluetooth both on iPhone and Android – no new Bluetooth devices discovered. I tried with power off, power on, plugging and unplugging. Nothing made a difference.

So I moved to my 2012 Mercedes SLK and plugged it in. Red light came on, but same non-responsiveness on both Android and iPhone. It then stopped showing the red light. Turns car on, off, removed key from range, nothing made a difference. So I then tried unplugging it as I had in the Leaf, but the plastic cover came off in my hand. I’ve been using OBD devices for years (currently have an Autel MP808), so I know how to handle them.

When I looked at the cover in my hand, I found a blue circuit board had fallen out. I removed the rest of the device. With a magnifying glass on the green circuit board I see brown on some contacts (see the photo)– suggesting either defective soldering or blown circuits. It’s possible someone returned this to Amazon and they sent it back out. Or you have a serious quality control problem...


And worse again:

Your message to [email protected] has been blocked. See technical details below for more information.
The response from the remote server was:
550 5.4.1 Recipient address rejected: Access denied. AS(201806281) [MW2NAM10FT042.eop-nam10.prod.protection.outlook.com 2023-02-07T08:22:58.008Z 08DB08BDCCDF7E01]