Cannot get P3102 to appear after swap

My Nissan Leaf Forum

Help Support My Nissan Leaf Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Mar 23, 2024
Hi everyone, hoping to get some answers to help my dad with his battery swap.

I spent the day helping my dad try to swap his 2015 Leaf 24kW battery with one he purchased on eBay. We got the swapped battery installed and P3102 does not appear in LeafSpyPro (confirmed latest version) no matter what we try. We can scan codes and clear them using all the steps in Dala's guide, but nothing we do gets P3102 to appear in the scan.

We've tried disconnecting the 12v battery (new in Feb24 and confirmed good charge) for 10 minutes, leaving the charger connected (though the car won't accept a charge), using the trickle charger (stays on ready mode).

Everything seems to indicate that the P3102 code will show right away, but we can't produce it in order to clear it.

Do you have any ideas why? Is the battery pack my dad bought bad somehow? Or too dead to charge? If so, how can we confirm this?
What are the symptoms of the car? You mention *not* getting an error code, but what is it doing other than not charging?

1) How many battery bars does it show (both the big and small bars)?
2) You don't have a charging timer, do you? If so, make sure to hit the charge timer override button to the left of the steering wheel. Heck, hit it anyway before plugging in the charger.
3) Can you post a LeafSpy snapshot of the battery? Does it read the cells and voltages? What are they?

If you swap a battery pack the car should charge and drive, even with a P3102 code, except that the turtle icon will be on the dash, so power will be limited (low acceleration, max speed 35 mph, etc). Are you able to put the car in drive mode?
Hi Lothsahn, thanks for the reply. Here is the summary I got from my dad

1) When the new battery was installed in the Leaf, no battery bars were shown, big or small. The battery percentage was just shown as three dashes. The car would show the electrical plug icon each time the charging cable was plugged in, but would not start the charging process.

2) No charge timers were or have ever been set. The car would not shift info Drive. I could get it to shift into Neutral, but nothing else.

3) I wish I would have taken photos of the dashboard status, but sadly I did not. Leaf Spy Pro would not show anything related to the battery. It showed all zero's for the battery serial number. We tried numerous times removing power from the twelve volt battery, removing and replacing the battery disconnect in the back seat and trying both the trickle charger that came with the car and the high speed charger from Emporia that we use to charge the car on a regular basis.

When we put the old degraded (1 bar) battery back in, everything worked as it had before.
It sounds like it could not recognize and talk to the battery. All the symptoms you mention sound like the car thought the battery wasn't there at all. Keep in mind the 12v will power the onboard computers, etc, so you don't need the main battery to wake up the car and communicate with the main battery.

You say "1 bar battery pack!?" What year is your car?!? I've never heard of a 1 bar battery pack in a Leaf before!

This doesn't sound like a 12v issue--it sounds like the battery wasn't recognized at all. There's a Gen1 and Gen2 battery and they talk different codes on the bus. You can't swap between them without a canbus adapter. I don't think this should be an issue for you because the connector is different between Gen1 and Gen2.

Few things to know:
1) What year is your Leaf? (I'm assuming 2015 since you say 2015 24kwh battery--but I have no idea how you have a 2015 battery at 1 bar! 2015's usually last a long time)
2) What year was the 24kwh battery you purchased?
3) You did connect the battery fuse (in the floor between the rear seats) to the new battery after you installed it, right?

It's possible your new battery has a fried battery controller or something. Assuming both batteries are the same generation, you could open them up and manually test the voltage of cells to ensure they're not dead (<2.5V/cell). If they're not dead, you could swap all the cells between the two packs, but it's not a job for the feint of heart, and EVEN with the battery fuse disconnected, you will be working with 200V+, so you need the right safety equipment and to be very careful.
If you can't getting any LeafSpy readings from the new battery, then there is something wrong with that pack (wiring/controller/bad modules/etc). If you can't get any proof that it was pulled from a working car before you got it, then any sort of troubleshooting would involve opening the battery pack (and equipment I suspect you don't have).
Oh yeah, Phoenix. I do NOT recommend Leafs in Phoenix! I've been there... gorgeous place but SO hot.